Error: Excessive bed leveling

My Prusa mk3s has been printing very reliably for weeks, pretty much since I set it up. I then went on a multi-day printing binge and somewhere near the end I ceased to be able to print anything via Octoprint. Any gcode sent to the printer would die during calibration. The printer would say "crash detected" and on the Octoprint side, it says this:

Your printer's firmware reported an error. Due to that OctoPrint will disconnect. Reported error: Excessive bed leveling correction: 2700 microns

If I put the same gcode on a sd card, the job will print without errors.

octoprint.log:

2019-10-30 10:10:39,870 - octoprint.filemanager.analysis - INFO - Analysis of entry local:Linear_Bearing_Greaser_-_LM8UU_0.15mm_PETG_MK3S_2h9m.gcode finished, needed 18.31s

2019-10-30 10:10:40,722 - octoprint.printer.standard.job - INFO - Print job selected - origin: local, path: Linear_Bearing_Greaser_-LM8UU_0.15mm_PETG_MK3S_2h9m.gcode, owner: dummy, user: dummy
2019-10-30 10:11:28,715 - octoprint.plugins.HeaterTimeout - INFO - Timer Started: 1572430288
2019-10-30 10:13:14,413 - octoprint.util.comm - INFO - Printer seems to support the busy protocol, will adjust timeouts and set busy interval accordingly
2019-10-30 10:13:14,421 - octoprint.util.comm - INFO - Telling the printer to set the busy interval to our "communicationBusy" timeout - 1s = 2s
2019-10-30 10:13:56,424 - octoprint.util.comm - INFO - Changing monitoring state from "Operational" to "Starting"
2019-10-30 10:13:56,437 - octoprint.printer.standard.job - INFO - Print job started - origin: local, path: Linear_Bearing_Greaser
-_LM8UU_0.15mm_PETG_MK3S_2h9m.gcode, owner: dummy, user: dummy
2019-10-30 10:13:56,499 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2019-10-30 10:13:56,533 - octoprint.util.comm - INFO - Changing monitoring state from "Starting" to "Printing"
2019-10-30 10:13:56,734 - octoprint.plugins.cancelobject - INFO - Not Tracking Extrusion
2019-10-30 10:13:57,132 - octoprint.plugins.tracking - INFO - Sent tracking event print_started, payload: {'origin': 'local', 'file': 'ab72bc1e54cf177dd3fa1821dcecf98e5390c5aa'}
2019-10-30 10:13:58,734 - octoprint.plugins.HeaterTimeout - INFO - Print started, timer stopped
2019-10-30 10:15:30,659 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Excessive bed leveling correction: 2700 microns
| Last lines in terminal:
| Send: N19 G80*41
| Recv: echo:busy: processing
| Recv: echo:busy: processing
| Recv: echo:busy: processing
| Recv: echo:busy: processing
| Recv: echo:enqueing "G1 E-1.000 F2700"
| Recv: echo:enqueing "G1 Z10.675 F800.000"
| Recv: echo:busy: processing
| Recv: echo:busy: processing
...
| Recv: echo:busy: processing
| Recv: Error:Excessive bed leveling correction: 2700 microns
2019-10-30 10:15:30,662 - octoprint.util.comm - INFO - Changing monitoring state from "Printing" to "Error: Excessive bed leveling correction: 2700 microns"
2019-10-30 10:15:30,678 - octoprint.util.comm - INFO - Force-sending M112 to the printer
2019-10-30 10:15:30,732 - octoprint.util.comm - INFO - Changing monitoring state from "Error: Excessive bed leveling correction: 2700 microns" to "Offline (Error: Excessive bed leveling correction: 2700 microns)"
2019-10-30 10:15:31,361 - octoprint.plugins.tracking - INFO - Sent tracking event commerror_firmware, payload: {'commerror_text': 'Excessive bed leveling correction: 2700 microns'}
2019-10-30 10:15:31,942 - octoprint.plugins.tracking - INFO - Sent tracking event print_failed, payload: {'origin': 'local', 'reason': 'error', 'commerror_text': 'Excessive bed leveling correction: 2700 microns', 'file': 'ab72bc1e54cf177dd3fa1821dcecf98e5390c5aa', 'elapsed': 94}

serial.log wasn't enabled :frowning:

Printer is mk3s running the most recent firmware (3.8.1) and running a 7x7 leveling matrix. As I mentioned earlier, the identical gcode will print without issue from the sd card. Octoprint is 1.3.12 on Octopi 0.17.0, running on an pi-4

Fixed by downgrading fw to 3.8.0

3 Likes