Error: Failed to enable bed levelling

What is the problem?

When printing a gcode file through OctoPrint the bed & nozzle will come up to temperature, they will both home and the nozzle will then probe the bed. At this point the printer will report an error with the following in the terminal window:

Send: N15 M420 S1 Z2*27
Recv: echo:Invalid mesh.
Recv: Error:Failed to enable Bed Leveling
Changing monitoring state from "Printing" to "Cancelling"

However if I print the same gcode file directly from the SD card plugged into the printer then it prints fine (with USB cable disconnected, see below).
The only other thing that is strange is that if I print the file from the SD card with the USB cable still connected I get some strange behaviour (pausing printing and parking the nozzle). However with the USB cable disconnected it prints with no issue every time. This was the reason for replacing the USB cable and trying a different USB port on the Pi.

The system has been working fine for a long time before all this happened. No recent changes to printer firmware and only routine updates to OctoPrint. No new plugins installed. Running in safe mode didn't make any difference which would remove plugins as being the problem.

What did you already try to solve it?

Reloaded the printer firmware - no change
Fresh install of OctoPi on a fresh SD card - no change
Replaced USB cable between Pi & printer - no change
Used different USB port on the Pi - no change

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (923.9 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version: 1.8.6
OctoPi version: 0.18.0
Printer: Creality CR10S Pro v2
Firmware: Nic Wilson's custom firmware for 12864 LCD instead of original touchscreen
O/S: Linux Mint 20.3
Browser: Brave & Chrome

Have you tried with/without SD card in the printer's SD card slot?

Yes I tried it with the SD Card both in and out with no difference.

However I think I have got to the bottom of the issue and it was basically operator error which roughly translates to me being an idiot.
I'm just doing some final testing to confirm and I will explain here.

What is likely happening is that the same error occurs, but there is no way of feeding this back to you. Most printers ignore errors on commands when they show up when printing from SD card, whereas OctoPrint reacts to them.

It could just be that you need to recreate the mesh by having the printer re-probe because it's got messed up somehow?

Thanks Charlie, you've confirmed my suspicions.

So what was happening was that I was performing the bed levelling in the printers control panel but I didn't realise that you then have to save the settings, I thought that once the mesh had been created it automatically saved it.
So then when I connect to the printer with OctoPrint it then resets the printer which was loosing the mesh and therefor giving the error.
I just couldn't understand why it was ok printing directly from the SD card but now that you've explained that it all makes sense.

Now that I've saved the mesh everything is working correctly again.

Every day's a school day as they say :grinning:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.