Error:Heating failed, system stopped! Heater_ID: bed

What is the problem?

Ender 3 Pro with 4.2.7 board Error:Bed Heating failed, system stopped! bed will not got over 50 degrees

What did you already try to solve it?

WRITE HERE

Did running in safe mode solve the problem?

no

Systeminfo Bundle

Attached

WRITE HERE

Additional information about your setup

Ender 3 Pro I had for 4 years, updated to 4.2.7 board last year.
running current firmware from marlin.crc.id.au : Ender3-v4.2.7-Stock-20240206.bin
OctoPrint : 1.9.3

Everything worked great on older firmware, I have just updated to the latest Marlin (tried several days of updates.

Hotend goes right up to temp, but the Bed once it hits 50 stalls for a few minutes and then trips error

octoprint-systeminfo-20240206030027.zip (11.2 KB)

Hello @LateOne !

This is the complete error:

2024-02-06 02:45:01,444 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Heating failed, system stopped! Heater_ID: bed - echo:busy: processing
| Last lines in terminal:
| Recv: echo:busy: processing
| Recv:  T:174.98 /175.00 B:51.23 /60.00 @:67 B@:45 W:?
| Recv:  T:174.98 /175.00 B:51.27 /60.00 @:67 B@:44
| Recv:  T:175.00 /175.00 B:51.26 /60.00 @:66 B@:45 W:?
| Recv: echo:busy: processing
| Recv:  T:175.01 /175.00 B:51.29 /60.00 @:66 B@:45 W:?
| Recv:  T:175.00 /175.00 B:51.32 /60.00 @:66 B@:44
| Recv:  T:174.99 /175.00 B:51.35 /60.00 @:66 B@:43 W:?
| Recv: echo:busy: processing
| Recv:  T:175.01 /175.00 B:51.36 /60.00 @:66 B@:44 W:?
| Recv:  T:175.03 /175.00 B:51.39 /60.00 @:66 B@:44
| Recv:  T:175.01 /175.00 B:51.37 /60.00 @:66 B@:45 W:?
| Recv: echo:busy: processing
| Recv:  T:175.02 /175.00 B:51.41 /60.00 @:66 B@:44 W:?
| Recv:  T:175.00 /175.00 B:51.45 /60.00 @:66 B@:43
| Recv:  T:175.00 /175.00 B:51.45 /60.00 @:66 B@:44 W:?
| Recv: echo:busy: processing
| Recv:  T:175.04 /175.00 B:51.47 /60.00 @:65 B@:44 W:?
| Recv: Error:Heating failed, system stopped! Heater_ID: bed
| Recv: echo:busy: processing

The bed can't reach the desired temperature, so the thermal runaway protection kicked in.
Some reasons:

  • Thermistor detached from bed
  • Insufficient power from the PSU (PSU dying)
  • Too cold in the room
1 Like

Thanks, I tested all your suggestions, with the same result every time.
I reinstalled the latest firmware from the Creality site and it goes up to 60 with no problem.

1 Like

there is the heater that heats. the temp sensor that senses said heat.
The heater is bad and/or the temperature sensor is bad. After so many readings nothing changes it will error.

replace both, one at a time, and test.
Let us know how it goes....