Error installing touchautostart

What is the problem?

I'm using the fintech guide to install a 3.5 touchscreen. When booting, the text goes to the touch screen so those drivers worked. When I run sudo ~/TouchUI-autostart/helpers/install, i get this:

[sudo] password for pi:
 ╔╦╗╔═╗╦ ╦╔═╗╦ ╦╦ ╦╦
  ║ ║ ║║ ║║  ╠═╣║ ║║
  ╩ ╚═╝╚═╝╚═╝╩ ╩╚═╝╩
Install helper v0.0.4

Boot to command line:
 - success

Running apt-get update (this will take a while)
Do NOT switch off the Pi or close this console until done!
 - failed
pi@raspberrypi:~ $

What did you already try to solve it?

used a clean install of Octoprint with only the touch plugin enabled.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I have the system bundle, but I can't see how to attach it to this.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


what happens when you run sudo apt-get update ?

It looks like I'm getting an error.

pi@raspberrypi:~ $ sudo apt-get update
[sudo] password for pi:
Get:1 buster InRelease [32.6 kB]
Get:2 buster InRelease [15.0 kB]
Get:3 buster/main armhf Packages [378 kB]
Reading package lists... Done
E: Repository ' buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

try to run

sudo apt-get update --allow-releaseinfo-change

and then again

sudo apt-get update

and check if the error is gone

1 Like

Thanks, that worked! I tried those so many times, I'm blaming it on my extreme dyslexia. I'm truly mystified.

No worries :slight_smile:
Now the touchui script should work again

1 Like

The fintech guide has an error. It's missing the second dash "ie -allow" instead of "--allow"

I have posted in the guide.

Thanks again!

1 Like

I was able to load the GUI, but calibration reversed x,y axis.
once I created the following file, the GUI fails to load, it boots to the Linux login prompt

From the same guide, I created the config file

You can now modify your 99-calibration.conf file

sudo nano /usr/share/X11/xorg.conf.d/99-calibration.conf

Copy and past below

Section “InputClass”
Identifier “calibration”
MatchProduct “ADS7846 Touchscreen”
Driver “evdev”
Option “Calibration” “3936 227 268 3880”
Option “InvertY” “true”
Option “InvertX” “false”