Error:Line Number is not Last Line Number+1, Last Line: 397320

What is the problem?

Printers randomly pauses at different intervals throughout a print. If i press continue on the printer it keeps on printing. sometimes it dosent happen at all sometimes it happens 5-8 times during a print, there does not seam to be a pattern.

What did you already try to solve it?

I was running Marlin 1.16 and have upgraded to the latest 1.19 or which ever it is. Have replaced the USB cable.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

Send: N397322 G1 F1650 X100.199 Y122.827 E2388.227147
Recv: Error:Line Number is not Last Line Number+1, Last Line: 397320
Recv: Resend: 397321
Recv: ok
Recv: ok
Send: N397321 G0 F9600 X100.199 Y122.866
Recv: T:200.10 /200.00 B:60.46 /60.00 @:66 B@:0
Recv: echo:busy: paused for user
Recv: T:200.17 /200.00 B:60.28 /60.00 @:64 B@:0
Recv: echo:busy: paused for user
Recv: T:200.10 /200.00 B:60.23 /60.00 @:65 B@:0
Recv: echo:busy: paused for user
Recv: T:199.94 /200.00 B:60.13 /60.00 @:69 B@:0
Recv: echo:busy: paused for user
Recv: T:200.14 /200.00 B:59.96 /60.00 @:64 B@:0
Recv: echo:busy: paused for user
Recv: T:200.31 /200.00 B:59.82 /60.00 @:59 B@:127
Recv: echo:busy: paused for user

I've searched the forums and web and no one has a straight answer or a fix so I open to suggestions. My printer is a Flsun I3 witha Mks 1.0 L Board if that helps.

Hello @Pablo_Hauber

Could you please share the

? Preferably attached here as files.

Also a high quality USB cable is mandatory and short as possible.

octoprint.log (955.0 KB)

Hi, I have just included the octoprint.log im not sure if this is the one your after? I'm currently printing again in safe mode and so far no issues. I haven't tried a new usb cable ... and my current one i about 1.5m long? could this be the issue? Also i forgot to mention that I can print perfectly fine from the SD.

The serial.log is quite handy. You may have to enable the serial logging first:

From SD is fine in most cases. This is an issue concerning the USB connection.

Most recommendations for the length of an USB cable is 1m. On my printers they are not longer than 30cm with additional ferrite beads on both ends.

This is an example of a unsufficient USB connection:

| Recv: echo:Unknown command: "ÂÅ31.021 Y74.321"

Also EMI can be a reason for transmission issues.

I've never seen a firmware react to a resend request with a user prompt on the display. That is... unusual and very much bad behaviour.

From the short excerpt of your terminal, what I can tell you is that your printer runs into a communication error, requests a line to be resent, OctoPrint complies, and then the printer decides it wants the user to press a button first. That is not really anything that OctoPrint can fix and sounds like something is severely wonky with that firmware build (or the communication issues are so severe that the printer thinks it received a command that requires a wait, but that would be quite a coincidence really).

In any case, I second the request for a serial.log, but I fear you'll need to take that up with the firmware, the printer connection or the controller.

Thanks for the response, I haven enabled serial Logging and will await for this this print to finish and post the long. I've also since switched to safe mode and have had 3 successful prints with no interruptions. I will keep printing in safe mode today to try and replicate the error.

Alright so after four successful prints Ive had the issue again but it does not seam to happen no where near as often is safe mode than normal.

I have uploaded the complete serial log below.