(Error: No more candidates to test, and no working port/baudrate combination detected.)

What is the problem?

Hi all, I’ll start with apologizing if the resolution has been posted somewhere already, I've read dozens of them and haven’t been able to find the issue yet with the suggestions that were made. I was able to connect to the pi and octoprint for a few weeks now without issue, serial port and baudrate set to auto. Made some mods a few days ago and haven’t been able to reconnect since, printer still powers and works fine). I can still connect to the pi via WiFi and ssh in with a Mac terminal. I show the /dev/ttyS0 serial port and a list of baudrates, tried all of them to no avail. Log files are below but here where the modifications I did

  • Added a 30 mm fan, connect to 5v and ground pin
  • Added a NO push power button to scl pin and ground, installed git clone https://github.com/Howchoo/pi-power-button.git./pi-power-button/script/install (after install button worked as designed and slept/woke the pi)
  • Added an Led status light to the ground and the txd pin, added enable_uart=1 to config.txt (after install worked as designed)
  • Spliced the canakit 5v power supply and installed a switch between it and the pi. (Plugged it in and tested the +- leads from the spliced cable as well as a 5v/ground pin, all read 5v with the multimeter with everything plugged in)
  • Cut and re-soldered a micro USB cable and eliminated the power lines (switched to another micro USB when issues started, pi is still powering the Ender 3 LCD when on)
  • Installed mesh bed leveler plug in

What did you already try to solve it?

I unplugged all of the mods, rebooted, trie safe mode

Have you tried running in safe mode?


Did running in safe mode solve the problem?

It did not

Complete Logs

Octoprint, serial, and dmesg attached
dmesg.log (19.6 KB) octoprint(1).log (749.1 KB) octoprint(1).log (749.1 KB)

Additional information about your setup

Ender 3 Pro, Marlin-bugfix-2.0.x
Raspberry Pi 3 B+
OctoPrint version : 1.5.2
OctoPi version : 0.17.0

I don't see any evidence of a printer serial device being detected in your dmesg. If the OS can't see it, OctoPrint won't see it. So you should look into why this is first. Check if your printer is detected as a serial device when plugged into a laptop or something.

Your printer should usually show up in OctoPrint as either dev/ttyACM0 or dev/ttyUSB0 when connected by USB.

Hi, thanks for getting back to me. I've never directly plugged the printer into a computer, so I'm not sure if it's supposed to immediately be recognized but I'm not seeing anything pop up, I checked the USB device tree and didn't see anything printer related show up, just the adapter I was using think. Tried it on a PC as well and the same thing. But like before, when I plug the USB into the printer, the printer turns on. I did upgrade to the reality 4.2.7-32 bit mainboard, but octoprint was working on that. In one of the threads I read I followed the advice from this poster as well, I'm not sure if that did anything to negatively affect it but I did find ttyAMA0 in list devices under the cd/dev. But it wasn't working before I did this either.

  1. Disconnect printer from USB, both can keep running
  2. Use putty and connect to octopi , default username is pi , default password is raspberry
  3. Navigate to /dev using cd /dev
  4. Use ls to list devices. Check if you can see ttyAMA0 and/or ttyUSB0 (it was the first for me)
  5. Use sudo del ttyAMA0 to delete the device, and do the same for USB0. You made a backup, right?
  6. Connect the printer to USB once again
  7. If you have auto-connect set up, simply restart your Raspberry Pi or just click the connect button.

The printer should now automagically connect as it used to.

dev/ttyAMA0 is the Pi's serial and has nothing to do with your printer. If the printer doesn't even get recognized on another machine I fear the mainboard/usb controller might be dead, at least it looks like it from here.

If you haven't yet tried at least 3 different USB cables, do so now. We have people all the time that make it work on the 2nd or 3rd try, some cables just don't work. Especially micro USB cables, some are charge only.

1 Like

Hmm, peculiar, thankfully amazon returns is easy! Im newish, but the USB port can still be "dead" even though it recognizes power from the USB? What are some of the things that might cause that so I can avoid it in the future. Thanks again for your advice!

Very good point by @Charlie_Powell there, might also be a broken cable or you accidentally swapped with a data-only cable.

USB has four pins, 5V, Ground, D+ and D-. If something about the latter two is broken either inside the cable (intentionally in form of power-only-cables or unintentionally) or on the board, power will still flow but data connection will be dead.

1 Like

@Charlie_Powell Well, that worked, I used the original cable I was using, it was only 6 inches long so I couldn't reach but I took the pi out of the mount to try. In my defense, I did try 3 other USB cables, before that and none of them worked. I got a right angle cable from amazon and snipped the +/- leads but I'm not sure why it's not working. I can try the tape on pin method for the next one. This might be a dumb question, is there a specific type of micro USB cable that works best (excluding power only USB types)?

You need the ground pin (- in your explanation) for the cable to function. The only one that can be cut and have it still function is the positive, the devices require a common ground.

Maybe I'll have to rephrase that to 4 :wink:

Considering the amount of shitty cables out there, maybe just make "try all that you can find, and if none of them work buy a new data cable and test THAT first".

1 Like

Do most cell phones that have a micro USB charging port also do data through that port? If so, one could test cables with a cell phone connecting to the RPi. This is what I got from dmesg:

[3869604.402583] usb 1-1.2: new high-speed USB device number 7 using dwc_otg
[3869604.533664] usb 1-1.2: New USB device found, idVendor=04e8, idProduct=6860, bcdDevice= 4.00
[3869604.533683] usb 1-1.2: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[3869604.533697] usb 1-1.2: Product: SAMSUNG_Android
[3869604.533711] usb 1-1.2: Manufacturer: SAMSUNG
[3869604.533724] usb 1-1.2: SerialNumber: 5200ac734bb99600

I took the USB cable that I cut the power to and reconnected the ground and it works like a charm. Much appreciated Charlie


Thanks everyone for your help and supporting the community!

1 Like