Error on login from Chrome

What is the problem?

Cant access octoprint web ui only from CHROME. From Edge or Firefox i access correctly, but from chrome (like i do since any time...) octoprint navigate to url:
http://192.168.0.5:5000/login/?redirect=%2F%3F&permissions=STATUS%2CSETTINGS_READ
and not login

What did you already try to solve it?

Clear navigator cache, try to inspect any error on login

Have you tried running in safe mode?

Yes, same error

Did running in safe mode solve the problem?

nop

Systeminfo Bundle

2022-10-15 15:57:50,084 - octoprint - ERROR - Exception on /plugin/logging/setup/levels [PUT]
Traceback (most recent call last):
File "/home/octoprint/OctoPrint/venv/lib/python3.9/site-packages/flask/app.py", line 2447, in wsgi_app
response = self.full_dispatch_request()
File "/home/octoprint/OctoPrint/venv/lib/python3.9/site-packages/flask/app.py", line 1952, in full_dispatch_request
rv = self.handle_user_exception(e)
File "/home/octoprint/OctoPrint/venv/lib/python3.9/site-packages/flask/app.py", line 1821, in handle_user_exception
reraise(exc_type, exc_value, tb)
File "/home/octoprint/OctoPrint/venv/lib/python3.9/site-packages/flask/_compat.py", line 39, in reraise
raise value
File "/home/octoprint/OctoPrint/venv/lib/python3.9/site-packages/flask/app.py", line 1950, in full_dispatch_request
rv = self.dispatch_request()
File "/home/octoprint/OctoPrint/venv/lib/python3.9/site-packages/flask/app.py", line 1936, in dispatch_request
return self.view_functionsrule.endpoint
File "/home/octoprint/OctoPrint/venv/lib/python3.9/site-packages/octoprint/server/util/flask.py", line 1552, in decorated_view
return func(*args, **kwargs)
File "/home/octoprint/OctoPrint/venv/lib/python3.9/site-packages/octoprint/access/permissions.py", line 183, in _decorated
rv = f(*args, **kw)
File "/home/octoprint/OctoPrint/venv/lib/python3.9/site-packages/octoprint/plugins/logging/init.py", line 134, in set_logging_levels_api
self._set_logging_levels(json_data)
File "/home/octoprint/OctoPrint/venv/lib/python3.9/site-packages/octoprint/plugins/logging/init.py", line 253, in _set_logging_levels
self._logger.manager.loggerDict[logger].setLevel(level)
AttributeError: 'PlaceHolder' object has no attribute 'setLevel'
2022-10-15 15:57:54,930 - octoprint.server.util.sockjs - INFO - Client connection closed: 192.168.0.10
2022-10-15 15:57:55,056 - octoprint.server.util.sockjs - INFO - New connection from client: 192.168.0.10
2022-10-15 15:57:58,250 - octoprint.access.users - INFO - Logged in user: octoprint
2022-10-15 15:57:58,253 - octoprint.server.api - INFO - Actively logging in user octoprint from 192.168.0.10
2022-10-15 15:57:58,436 - octoprint.server.util.sockjs - INFO - Client connection closed: 192.168.0.10
2022-10-15 15:57:58,561 - octoprint.server.util.sockjs - INFO - New connection from client: 192.168.0.10

I thought I was the only one with this issue.

I've found that the extension "I don't care about cookies" doesn't play well with octoprint, and having that chrome extension enabled makes it impossible to login to the server.

Maybe that will help you.

1 Like

this issue is much larger then octoprint. chrome has discontinued support for http and only supporting https. your temporary option is to use edge in ie compatibility mode. hopefully octo guys will have a patch and instructions to enable https and certs.

octoapp will still work to access the server.

Do you have a source for this? I believe it is misinformation.

I wish it were miss info. Unfortunately google announced a year ago. At my work place we have been actively addressing any pubic facing applications which are not using https. I was first hit by it with my new work laptop. Once your chrome is updated your up a creek. Several of our site stopped working in chrome ...

If You google it you'll find an announcement from google. I don't know the full details whether it http in general or just mixed sites. It's a pain in the butt...

I mean yeah on February 6, 2020, Google announced they would be starting to ending their support of HTTP pages in the Chrome browser.

But I havn't been able to find any news that they have actually done it.

Sorry, but without a link to a credible source I still am not going to believe they have just got rid of http support. 'google it' is not good enough for a source, when I tried to Google it and couldn't find any relevant information about http support going away. Either you have a link to an announcement from Google or it doesn't exist in my view.

In my case, the extension was uBlok Origin, as simple as disable the extension on octoprint.

Thanks for the hint, I hadn't thought about it

1 Like