Upon upgrading to 1.9.0 I can catch this on the console screen before the server reboots:
"ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
sentry-sdk 1.24.0 requires urllib3<2.0.0, but you have urllib3 2.0.2 which is incompatible."
What did you already try to solve it?
Came to the forums to ask.
Have you tried running in safe mode?
No as it happened when upgrading core Octoprint.
SO I'm just wondering if it's a matter of outdated packages or anything "broken" in my instance.
Most likely some hard pins by plugins that are now causing issues (as in, that warning) with OctoPrint's updated dependencies.
Sadly plugin authors seem to happily hard pin specific versions of things that OctoPrint also relies on. They shouldn't, but some do. So when I now update the core dependencies, to make sure y'all get newer versions with bug and security fixes pulled in, but some plugin earlier got installed with a hard pin on an earlier version, you get that message. Things should continue to work still. It would be best if the plugin authors in question could stop hard pinning (package == version) and instead use version ranges.
Not sure if this is useful, but when I use "pip3 show urllib3" (from oprint venv) the only "required-by" packages listed are "requests, sentry-sdk". The requests package calls for "urllib3 (<3,>=1.21.1)". The sentry-sdk package (for python 3.9) calls for "urllib3 (<2.0.0)" and "urllib3 (>=1.26.11)". So, I don't see any plugin or anything else that is "hard pinning" a requirement for the older urllib3 package (but my understanding of pip/python easily fits inside a thimble with room to spare, so I may be missing something here).
In any case... I manually updated (pip3 install "urllib3==1.26.16"), and so far have not seen any problems.