Error setting up pi


#1

What is the problem?
When setting up octoprint on my raspberry pi using the directions from the linux wiki, I get an error about unicode. It is after I run the ~/OctoPrint/venv/bin/octoprint serve line, and it gives me

Traceback (most recent call last):
File "/home/pi/OctoPrint/venv/bin/octoprint", line 11, in
load_entry_point('OctoPrint==1.3.8', 'console_scripts', 'octoprint')()
File "/home/pi/OctoPrint/venv/lib/python3.5/site-packages/OctoPrint-1.3.8-py3.5.egg/octoprint/init.py", line 564, in main
from octoprint.cli import octo
File "/home/pi/OctoPrint/venv/lib/python3.5/site-packages/OctoPrint-1.3.8-py3.5.egg/octoprint/cli/init.py", line 137, in
from .client import client_commands
File "/home/pi/OctoPrint/venv/lib/python3.5/site-packages/OctoPrint-1.3.8-py3.5.egg/octoprint/cli/client.py", line 166, in
@click.option("--str", "-s", "str_params", multiple=True, nargs=2, type=click.Tuple([unicode, unicode]))
NameError: name 'unicode' is not defined

I'm not quite sure how to fix it either.

What did you already try to solve it?
I made sure that my python version was 2.7.13 and also tried the ./venv/bin/python setup.py install with python3 and python3.5 as well.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
I am running this on the desktop version of raspbian, and have not connected my printer yet as I was going to do that after I got this working once. Additionally, (I'm not sure if this changes anything) I am on a larger network where I register my devices through their MAC address, and the pi is connected to it.


#2

For whatever reason, your machine uses python 3 as the default python. It needs to be v2.7.x; octoprint isn't supported in 3.x yet.

Also, please use markdown to format your coffee and logs next time.