Error starting OctoPrint on windows

What is the problem?

Error getting OctoPrint to start I've installed on another PC moved printer to new area and newer PC now trying to install and get it running here seemed to run into a snag

What did you already try to solve it?

I've uninstalled and reinstalled python and octoprint

I've done pip install --upgrade --force-reinstall https://get.octoprint.org/latest

also I tried pip install --force-reinstall --no-cache-dir OctoPrint

Have you tried running in safe mode?

yes

Did running in safe mode solve the problem?

no it didn't same errors

Systeminfo Bundle

don't have can't get it to start

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.8.6
Chrome
Windows 10
Python 3.11.0

octoprint.log (59.1 KB)

Switched to python 3.9 and it worked... lesson learned

1 Like

Python up to 3.10 should work, 3.11 has just been released and there are a couple of incompatibilities. The next OctoPrint release already has the fixes in, until then 3.11 won't work. I'll make sure to adjust the setup guide to point this out temporarily, since at the moment it says 'latest'.

1 Like