Error! System is currently throttled, refusing to install anything due to possible stability isssues

What is the problem?

I was trying to install a new pluggin for full screen webcam in octoprint, and my Pi 4B kept showing up with "Error!
System is currently throttled, refusing to install anything due to possible stability isssues"

What did you already try to solve it?

I have used the power supply buck converter from the printer to the pi, with 2 different usb cables, and an alternate external power brick. The lightning bold doesn't show up, so I don't think it's under powered? I even tried the tape mod for the printer usb cable. I have also restarted the printer and the pi connected, and disconnected several times

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Safe mode won't let me install the new plugin I was trying to set up...

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

octoprint.log (219.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
As far as I know, I am running the newest versions of everything, as I set everything up less than a week ago (and it was working fine for a few days) the Pi model is the 4B with a 16gb sandisk ultra micro SD card, plugged into my Prusa i3 Mk3s+ with a buck converter stepping the 24v down to 5 (previously attached to a under powered usb hub)

Hello @Fantaku !

In fact, your Pi is underpowered:

2021-03-14 02:25:43,980 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.
2021-03-14 02:25:43,995 - octoprint.environment - INFO - Detected environment is Python 3.7.3 under Linux (linux). Details:
|  hardware:
|      cores: 4
|      freq: 1500.0
|      ram: 1903988736
|  os:
|      bits: 32
|      id: linux
|      platform: linux
|  plugins:
|      pi_support:
|          model: Raspberry Pi 4 Model B Rev 1.2
|          octopi_version: 0.18.0
|          throttle_state: '0x50005'

I had hoped the buck converter on the Mk3 power supple should be enough though? and I don't see the lightning bolt? The separate power supply didn't work either, what else could I do? It allowed me to install plugins before when it even had the lightning bolt on the power strips built in USB ports, which is why I'm confused...

Had the same problem but fixed it with changing to an official power supply, Pi now runs quicker and no problems

1 Like

Thanks, I'll give that a try I guess :+1: