Error when attempting to flash

I have attempted to flash Octoprint using Etcher. I have installed the latest versions of everything. I've uninstalled and reinstalled and checked everything I could and yet I still get this error when I try and flash and can't find any answers. Please help!

Raspberry pi4 4g Brand new.


Something went wrong. If it is a compressed image, please check that the archive is not corrupted.


I have attempted to open the file AFTER unzipping and it states that the file is corrupt.

Maybe an Etcher bug.
Try Win32DiskImager

That may have worked! Thank you. Now I'll pray that the rest of installation goes well. Thank you so much!!

I'm sorry to say that your suggestion didn't work. I'm still getting "corrupted file"

Then it's probably really corrupted.
Try to download the image again

I have 6 times, different sd cards. Files look good but when plugged into the Raspberry, all I get is a red light and never completes the boot. And I can't see it in my network even after making the correct adjustments. I've tried using THREE different image flash programs.

Are you sure it's a 4GB pi and not the 8GB model?
If you're sure check the bootloader:

To check that the bootloader is working correctly, turn off the power, unplug everything from the Raspberry Pi 4, including the SD card, and then turn the power back on. If the green LED blinks with a repeating pattern then the bootloader is running correctly