Error while getting temperature data from Octoprint connected to Creality Ender S1

What is the problem?

While giving GET http://octopi.local/api/printer command in POSTMAN, below error is displayed : "You don't have the permission to access the requested resource. It is either read-protected or not readable by the server "

What did you already try to solve it?

Given access permission to Guest user group for "STATUS" in the access control option.

What might be the problem and how to resolve it?

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


You'll need to use an API key to access the resources through postman for now, due to a long time bug that prevented use of the API as a guest without a session cookie. It has been fixed for 1.9.0.

This worked. Thank you.
Can you please share how to include the API key in Python code for using requests.get()

Got the code. Was trying in google colab where it didnt work. Code running successfully in RPi

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.