Error while reading repository data

What is the problem?

When trying to install Octoprint plugins, I get an error message that there was an error while reading the repository data:

2023-05-22 09:14:58,617 - octoprint.plugins.pluginmanager - ERROR - Error while reading repository data: Expecting property name enclosed in double quotes: line 13592 column 8 (char 481228)

Those are the "offending" Lines
13591 "id": "karmen",
13592 "published": "2022-08-15 00:00:00 +0000",
13593 "title": "Karmen Connector",

What did you already try to solve it?

Restart the server multiple times

Have you tried running in safe mode?

No, because it looks like a corrupt JSON may be the culprit

Did running in safe mode solve the problem?


Systeminfo Bundle (6.0 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.8.7 on Armbian 22.11.0-trunk Bullseye with bleeding edge Linux 6.1.11-sunxi running on a Banana Pi M2 Ultra

You can try to install via the url:

[type or paste code here](

within the Plugin Manager

Thank you for your reply.

That would not solve my problem sadly, because the issue here is that I do not see any plugins because the loading from the repository fails.

I took a screenshot to show what I mean, please ignore the message of an ongoing print, the error regarding the repository also appears when not printing.

Just to be sure I tried to install the plugin you pasted and install it manually, but this also fails, although the error here seems to be related to another issue I found while searching for an answer to mine, being that the building of the wheel fails.

I will try to resolve that issue as soon as my print finishes, maybe it fixes my repository problem as well.

1 Like

Hi Philipp,

this is definitely a very abnormal error.

2023-05-22 09:14:58,550 - octoprint.plugins.pluginmanager - INFO - Loaded plugin repository data from
2023-05-22 09:14:58,617 - octoprint.plugins.pluginmanager - ERROR - Error while reading repository data: Expecting property name enclosed in double quotes: line 13592 column 8 (char 481228) Traceback (most recent call last):

Lines 288,289 in the octoprint log you provided, complains about missing quotes read from a file from a plugins web page and viewing the web page I see quotes in exactly the spot where it complains about the missing quotes.

      "id": "karmen",
      "published": "2022-08-15 00:00:00 +0000",
      "title": "Karmen Connector",

Earlier in the log on line 49 it states however that it can not check for updates, so is the pi able to access the web or not?

2023-05-21 21:07:53,570 - octoprint.plugins.softwareupdate - ERROR - Could not check octoprint for updates Traceback (most recent call last):

If it has web access, and it's capable of reading the plugins file, then the file gets corrupted or it's a cached file that kept on being loaded. It might also be a similar issue of a file being read and getting corrupted.

In my experience these types of issues are normally related to hardware problems.

  • Is the pi connected over wifi or ethernet cable?
  • Are you getting low power messages from octoprint?
  • You might have a failing SD card, scan and check the SD card, I had several of them failing on my Pi's.

I hope this helps some.

Thank you as well for your input.

To your points:

  • Yes, the Pi is able to connect to the internet perfectly fine (ping average 24ms)
  • No, I do not receive any low power warnings, and I have specifically bought the beefiest wall plug I could get with micro USB (3 Amps) in order to rule out any of those issues
  • The SD card worked perfectly fine while being in my Pihole, so that seems unlikely, but I will try another SD card nonetheless (and reinstall Octoprint in the process, which might resolve this issue anyway, I just did not do that yet because I want to finish a printing project and don't want to switch over to SD card directly at the printer midway).

I agree that this is an abnormal error (although I tend to attract those :expressionless: ), moreso because there are hundreds of quotation marks before the offending line, so I would also rule out any charset errors here.

I have seen that it is possible to manually provide the location of the plugin repository, I will try that as soon as I get home from work, if that does not help I will reinstall, and if THAT does not help either I will switch my Pi 3B+ Pihole with the Banana Pi and simply flash Octopi. I wanted to keep the "authentic" Pi in reserve for my Voron project, but seeing as this issue might be highly specific and not easily solved I might just give in and try to source another Pi somehow. It should get better in a few weeks I understand.

Best regards!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.