Etcher returns an error but the install works

Hi, I'm brand new to both Pi and Octoprint but not to programming.

I've just installed the latest version of Octoprint onto a 32GB samsung card using etcher on windows and it seems to flash OK but returns an error. Despite this, the install does actually work when connected to a Pi3b+

I have tried using a different PC, with a different card adaptor, a different SD card and different version of windows and still get the error.
I have tried telling Etcher not to unmount
I have tried formatting the card as exFAT with SDformatter

Unfortunately I just don't know enough about what is going on and any advice would be very welcome

...AppData\Local\Programs\balena-etcher\resources\app.asar\node_modules\raven-js\dist\raven.js:58 Warning: Can't perform a React state update on an unmounted component. This is a no-op, but it indicates a memory leak in your application. To fix, cancel all subscriptions and asynchronous tasks in the componentWillUnmount method.
in FlashStep (created by MainPage)
in div (created by MainPage)
in div (created by styled.div)
in styled.div (created by ForwardRef)
in ForwardRef (created by Component)
in Component (created by ForwardRef)
in ForwardRef (created by ForwardRef)
in ForwardRef (created by Box)
in Box (created by Flex)
in Flex (created by MainPage)

Hello @bladeslapper!

What error?

It says "Flash Complete - 1 failed device" and then on mouseover it says checksum does not match. I can copy the rest of this if that helps.

On the console, there is 1 error and 1 warning.

The error is what I copied and pasted into my original post and the warning is:

...AppData\Local\Programs\balena-etcher\resources\app.asar\node_modules\react\cjs\react.development.js:315 Warning: React.createFactory() is deprecated and will be removed in a future major release. Consider using JSX or use React.createElement() directly instead.

You may try an older version of Etcher or Win32 Disk Imager

I tried win32 disc imager. It writes OK just like etcher. There is a "verify only" option which I tried after the install and it says "verification failed at sector: 8192"
unfortunately again I have no idea what this means.
I will have a go at finding an old version of Etcher now.

I've just tried using etcher 1.5.62 which is the release from approximately the same date as the latest version of OctoPi.
I had a similar result. It completed the flash but still says "1 failed device" however it's a different error. This time:

[withTheme] You are not using a ThemeProvider nor passing a theme prop or a theme in defaultProps in component class "Component"

Am I worried about nothing? Are these errors normal? Sorry no experience of Pi at all!

thanks for your help so far

It seems there is an issue with the SD card. Just one faulty bit can ruin your day.

try it again with every other Program closed except Etcher,
I think I had the same error.

I suspect a Program wrote something to the SD after etcher finished writing to it but before checking it so the checksum changed. (I’m suspecting Prusa Slicer was it for me)

I seem to have made it work but I'm not 100% happy.

It has now loaded the image onto 2 different cards (the ones I have been using all along) and it has not given me an error on the main screen of Etcher however in the Console I am still getting either of the 2 errors posted above depending upon which version of Etcher I am using.
The only thing I have changed is that I have aggressively turned off all the services that are commonly running on both my PCs such as Dropbox, OneDrive, Mega. I have also followed the instructions here:

I'm not sure if any of this actually helped or if it was just good luck!

I hope this helps someone else with some suggestions in the future.

Thanks all for the guidance.