Every few weeks OctoPrint stops connecting to wifi

Every few weeks I find myself unable to connect to my OctoPrint. When I check my router it says that OctoPrint is not connected to the wifi after these few weeks. Everything works 100% fine until the fateful day where I click the on button and it doesn't work. All lights are turning on and blinking as they are supposed to. It does the standard printer boot up with fans turning on and whatnot. I have tried using different networks and an ethernet cable. I can only get access again after re-flashing the micro-sd card.

I am running it off of a Raspberry Pi 3B+.

Re-flashing the micro-sd card seems like a pretty large hammer but I'll bet you didn't find that "solution" without trying a lot of other things first. If you want our help, you need to take the time to list those other things along with logs and any other details that might help us help you.

The title of your post says stops connecting to WiFi but you mention you tried an ethernet cable which should eliminate any issues with WiFi.

Re-flashing every few weeks is quite painful. When OctoPrint is working I can check my router and it will list "Octopi" as a connection. After it flops it no longer shows up and when I use ethernet it doesn't change anything. Finally, how do I access logs?

The first step would be to click on the link that is automatically created every time someone types logs.

The next time you re-flash the micro-SD card, don't bother with Wi-Fi setup but instead plug in the ethernet cable. In most environments, no configuration on the RPi is necessary, it should connect to your network and be visible on your router as "Octopi" just like before. If it isn't visible right away, capture the logs and post them here. If it is visible, leave this configuration alone for a few weeks and see if it disappears. If it remains stable for twice as long as your previous WiFi record, then you can report back here and that will be a useful data point should we then pursue troubleshooting your WiFi problem.

Thank you, I will take your advice next time it acts up.

Hey! I know its been a long time but the issue has re-occurred. After further research it seems the Pi was unable to read the boot file. My easy solution was to flash a new card and transfer the new boot file to the micro-sd card, which worked. I can keep all my plugins and data just by giving it one new file. This is an easy solution that I don't mind doing every once in a while but I'm still curious as to why this happens. I don't need anymore help but if you do have any ideas feel free to list them.

BTW: Do you shutdown the Pi via the menu or do you just pull the plug?

The Pi I bought came with a small on/off button on the power cable which I use. In the future should I only use the power button in the octoprint menu?

1 Like

Yeah. The filesystem could get corrupted if you just pull the plug or press the on/off button on your power cable.

1 Like