Extruder do not feed filament since update to 1.5

What is the problem?

Since the update to 1.5 yesterday ... when I'm printing
The extruder is not moving and do not feed filament to the hotend .
Aside of this , the same Gcode does not behave the same as when started from SD card
as if the start gcode I've set is not fully understood.

What did you already try to solve it?

As not working from SD ... I thought it was a clog ... I cleaned everything
I decided to start a print from SD ... and "miracle" everything works fine

Have you tried running in safe mode and if so did it solve the issue?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Send: N298 G1 X108.03 Y96.725 Z0.3577
Recv: ok
Send: N299 G1 X107.624 Y96.288 Z0.35
Recv: ok
Send: N300 G1 X107.2 Y95.722 Z0.35119
Recv: ok
Send: N301 G1 X106.485 Y94.591 Z0.35
Recv: ok
Send: N302 G1 X106.257 Y94.293 Z0.35120
Recv: ok
Send: N303 G1 X106.0 Y94.008 Z0.35
Recv: ok
Send: N304 G1 X105.712 Y93.74 Z0.3569
Changing monitoring state from "Printing" to "Pausing"
Recv: ok
Send: N305 M400
Recv: ok
Send: N306 M114*34
Recv: X:105.71 Y:93.74 Z:0.35 E:0.00 Count X:8489 Y:7574 Z:140
Recv: ok
Changing monitoring state from "Pausing" to "Paused"

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint Version 1.5.0
Version 0.17.0, running on Raspberry Pi 4 Model B Rev 1.1
Printer Geeeteech A20M Marlin 1.1.8
Win10 ( any browser )

You didn't try or it didn't solve the issue? If you didn't try, please try.

And share complete logs. Not an excerpt. And both octoprint.log and an enabled serial.log.

I have the same issue in Ender 3 v2.
I use both Cura and Pursaclicer and send it to Octoprint but it print only air then with the same sliced object I save the file to micro SD card, initiate print from printer LCD and it can print well.
serial.log (740 Bytes)
octoprint.log (1.1 MB)

You need to enable the serial.log and repeat the experiment. Use the blue link for detailed instructions.

Just tried to print in safe mode and work as expected but again no filament was extruded when print in normal mode.

serial-3.log (8.7 KB)serial-4.log (72.6 KB)

Another user reported this issue and it was because they had installed the GcodeLeveling plugin. Is that the case here? It looks like it based on the octoprint.log. You may have to re-upload your files.

Gosh, you are very right!!
I disable the plugin, restart server and now it can print as expected.
Thanks so much

I've also blacklisted the GcodeLeveling plugin on the repository for this reason. I guess I should also push out a notice in addition to that, just in case.

Sorry I saw the others messages quite late ... the plugin was already black listed ... ( even if I also see a update of that plugin )

It's indeed working better now :slight_smile:

I'm still new to octoprint ... sorry I'll keep the safe mode in mind next time

Thanks a lot