Extruder doesn't work with octoprint

What is the problem?

Extruder doesn't work with octoprint

I installed octoprint on raspberry pi 4 Band connected with my printer. I had problem with e step after changed my main board because of board malfunction.
Refer to this site(https://teachingtechyt.github.io/calibration.html#esteps), origin estep=5.00, measurement between mark on filament=77.9. so I entered on terminal
M92 E21.93

After calibration, I tried to extrude 100mm of filament, but nothing extruded.

If I try extrude with printer display(without octoprint), it extrudes a little, about 5mm.

What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?

Nothing solved.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20231010123028.zip (34.6 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Octoprint 1.9.3
octopi Build 2023.10.09.151442, based on OctoPi 1.0.0, running on Raspberry Pi 4 Model B Rev 1.4
pritner kingroon kp3s 3.0

how did you try to extrude filament? via the terminal? if yes - which gcodes did you use exactly?

Did you heat the extruder first? Nozzle has to be above a certain temp before it will extrude on most printers... has to be over 160 or 180⁰C

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.