Extruder not turning after laying down initial two lines

Hi folks,

I am new to 3D printing and this is my first post, so my apologies if my post isn't well written.
I have an Ender 3 V2 which is working fine in its original configuration (however with Marlin firmware), and recently I bought a Creality Sprite hot end (same as in the Ender S1 I believe) as I would like to print some flexible materials.

Now here is problem: When printing the same gcode as on the original V2 configuration, the printer lays down the initial lines on the L/H side of the print bed, and then the extruder retracts a very tiny amount as it moves to the skirt. However, from then on the extruder does not move any more at all, although the printer still moves in XYZ. (GCODE at the end of this post)

Even stranger, the very first time I started the print of a 3Dbenchy, it was printing - but I cancelled the print as I needed to go out. After that - nothing. I thought that maybe I blocked anything as I didn't move the nozzle away from the print.

What did you already try to solve it?

The nozzle isn't blocked, the filament isn't retracted beyond the extruder wheels, as I can manually extrude any amount of filament.

I tried to turn on the runout sensor on the Marlin software but that didn't change anything.
I don't have the Octolapse plugin which was identified in another post as the possible culprit.

Have you tried running in safe mode?

No I haven't - I am having the same problem even when printing from the SD card.
So probably not an Octoprint issue but I don't know where else to turn to.

Systeminfo Bundle

browser.user_agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:101.0) Gecko/20100101 Firefox/101.0
connectivity.connection_check : 1.1.1.1:53
connectivity.connection_ok : True
connectivity.enabled : True
connectivity.online : True
connectivity.resolution_check : octoprint.org
connectivity.resolution_ok : True
env.hardware.cores : 4
env.hardware.freq : 1400.0
env.hardware.ram : 914006016
env.os.bits : 32
env.os.id : linux
env.os.platform : linux
env.plugins.pi_support.model : Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version : 0.18.0
env.plugins.pi_support.octopiuptodate_build : 0.18.0-1.7.3-20220323100241
env.plugins.pi_support.throttle_state : 0x0
env.python.pip : 20.3.3
env.python.version : 3.7.3
env.python.virtualenv : True
octoprint.last_safe_mode.date : unknown
octoprint.last_safe_mode.reason : unknown
octoprint.safe_mode : False
octoprint.version : 1.8.1
systeminfo.generated : 2022-06-11T10:07:05Z
systeminfo.generator : zipapi

Additional information about your setup

OctoPrint Version 1.8.1, OctoPi Version 0.18.0, running on Raspberry Pi 3 Model B Plus Rev 1.3, Ender 3 V2 with Sprite hot end, Marlin, Firefox, Windows 10

GCODE:
Here is the start of the gcode (XYZ calibration cube) which prints fine with the V2 original head.

;FLAVOR:Marlin
;TIME:2665
;Filament used: 1.77583m
;Layer height: 0.2
;MINX:96.5
;MINY:96.5
;MINZ:0.2
;MAXX:138.5
;MAXY:138.5
;MAXZ:20
;ZOFFSETPROCESSED
;Generated with Cura_SteamEngine 5.0.0-beta+1
M140 S70
M105
M190 S70
M104 S235
M105
M109 S235
M82 ;absolute extrusion mode
; Ender 3 Custom Start G-code
G92 E0 ; Reset Extruder
G28 ; Home all axes
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
G92 E0 ; Reset Extruder
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish
G92 E0
G92 E0
G1 F2700 E-6
;LAYER_COUNT:100
;LAYER:0
M107
G0 F6000 X99.698 Y99.764 Z0.3 ;adjusted by z offset
G92 Z0.2 ;consider this the original z before offset
G0 X96.501 Y108.025
;TYPE:SKIRT
G1 F2700 E0
G1 F900 X96.51 Y107.36 E0.02212
G1 X96.563 Y106.424 E0.0533
G1 X96.695 Y105.495 E0.08451
G1 X96.906 Y104.581 E0.11571
G1 X97.194 Y103.689 E0.14689
G1 X97.557 Y102.824 E0.17809
G1 X97.992 Y101.993 E0.20928
G1 X98.496 Y101.203 E0.24045
G1 X99.066 Y100.458 E0.27165
G1 X99.698 Y99.764 E0.30287
G1 X100.386 Y99.127 E0.33405
G1 X101.126 Y98.551 E0.36524
G1 X101.912 Y98.039 E0.39644
G1 X102.739 Y97.597 E0.42763
G1 X103.601 Y97.227 E0.45883
G1 X104.491 Y96.931 E0.49003
G1 X105.403 Y96.713 E0.52122
G1 X106.33 Y96.572 E0.5524
G1 X107.201 Y96.513 E0.58144
G1 X107.83 Y96.5 E0.60236
G1 X126.793 Y96.5 E1.23308
G1 X127.649 Y96.511 E1.26155
G1 X128.585 Y96.565 E1.29273
G1 X129.513 Y96.697 E1.32391
G1 X130.427 Y96.909 E1.35511
G1 X131.319 Y97.198 E1.3863

You maybe accidentality did not post the systeminfo bundle:

Here is the bundle - I struggled yesterday to attach it. Rookie error...
octoprint-systeminfo-20220611110705.zip (2.3 MB)

I thought that i had some success yesterday: I turned on "Relative Extrusion" in Cura and it did actually printed. But today it didn't , so I'm back to square one.
The only thing I did that was out of the ordinary was a PID Autotune (M303) as the new hot end temperature wasn't stabilising.

Any help would be appreciated!

Cheers,

Kurt

There is this in your start code.

The filament is retracted an amount of 6 mm after the initial lines.
But when it comes to start the print, this amount is not deretracted.

There should be a

G1 F2700 E6

just before the ;TYPE:SKIRT

Hi Ewald,

Thanks heaps for your reply. I had already noticed the retraction setting of 6 mm which probably was the default for the original Ender 3 V2 configuration. I had changed it to 0.8 mm which is what I read somewhere for the Sprite. But as you mentioned, it wasn't deretracted. So I just tried with the additional deretraction command you mentioned but it didn't change anything.

Initially I had some success by resetting the firmware and then re-entering the E steps value for the Sprite. I was able (initially) to print the calibration cube to various levels when the extruder stopped again. I think the extruder driver may be getting disabled by a temperature sensor - but I may be completely wrong here.
Since the Creality tech support also hasn't been able to help, I have now contacted Creality sales and asked for a refund. Let's see how that goes...

Thanks again!

Kurt

Hi all,

Creality has now sent me a new unit (I would have preferred a refund ...) and I have done some testing over the weekend. So far it's working, so it looks like it was just a faulty unit.
Thanks again for your help !

Kurt

1 Like