Extruder only extrudes after first using the manual controls to extrude

What is the problem?

I have been using Octoprint for a while and it always worked without issue. Recently I have been starting to get the issue where my printer does not extrude when starting prints from Octoprint. SO i start the print and the X,Y,Z move accordingly but the E just does nothing. It isn't skipping or anything but the gear does not turn.

Here is where the weird things start

When i then stop the print, extrude a bit of material through the controls in Octoprint and start the print again it works without issues. Also when starting the same print from the SD Card it also works properly.

What did you already try to solve it?

  • Reinstalled the latest version of Octoprint
  • Only installed the Creality Temp fix and Creality 2x temp fix plugins
  • Flashed new Jyers firmware to the printer (before i had the stock Creality Marling Firmware)
  • Checked the extruder cable, and checked if it was connected on both sides
  • Switched the USB cable between my Pi 3B and the printer
  • checked G-code for any weird things and found nothing.

Have you tried running in safe mode?

Not yet

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)octoprint-systeminfo-20211231100807.zip (51.4 KB)

System info bundle is uploaded allong

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

  • OctoPrint 1.7.2
  • OctoPi Version 0.18.0, running on Raspberry Pi 3 Model B Plus Rev 1.3
  • Printer Ender 3 V2
  • Firmware: Jyers E3V2-Default-v4.2.7-v2.0.1.bin

Please try the safe mode first so we can rule out the plugins

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.