Extruder temperature is not shown on the graph

Extruder temperature is not shown on the graph.
In the terminal window I see the messages from printer like this

Recv: ok EX1:23.1 /0.0 @0 EX2:23.1 /0.0 @0 B:22.6 /0.0 @0

The temperaturre for the bed is shown correctly at the graph
But temperature for both ectruder is empty (not shown at the graph)

I suppose that octoprint didn't understand that EX1 and EX2 is the value for the extruders temperatures

Can this be fixed?

No, it's expecting something along the lines of T or T1 and T2.

A plugin could do it. There's already a couple for similar cases:

Neither of those would fix this case, but the concept is the same.

Alternatively, you could update the firmware on your printer to one that outputs the expected format

Which printer vendor decided to change crucial protocol messages without any cause or reason here please? Just so that I know who to blame the next time something like this shows up in the support channels?

Printer manufacturer Imprinta
Printer "Hercules strong duo" model of 2019 year

The printer manufacturer promt that EX1 can be changed to T1 in the printer settings.
I changed the settings, now the line from printer looks like this

Recv: ok T1:59.0 /0.0 @0 T2:52.5 /0.0 @0 B:32.6 /0.0 @0

But that didn't solve the problem. The extruders temperatue at the graph is empty
What's wrong this time?

Did you specify the number of extruders in the printer profile in your OctoPrint settings?

First extruder should be T0, the second T1


1 Like

Yes, this solved the problem
First extruder T0 second T1



So can you please: