F and Kernel panic

What is the problem?

Trying to install Octoprint on my rasberry pi 4 model B. Upon installation I ge the following error, "F and Kernel panic - not syncing: VFS: Unable to mount root f an unknown block (0,2) 1---

What did you already try to solve it?

I have tried making multiple flash drives boot loaders for the pi. I have tried to install it multiple times on different flash drives. I am going to the Rasberry pi imager. I select Other specific purpose OS, 3d printing, and Octopi. I then stick the flash drive into the Pi and let it do its thing. It stops at the F and Kernel panic.

Have you tried running in safe mode?

No clue how to do this, I can't get it to install at all.

Did running in safe mode solve the problem?

Please see above.

Systeminfo Bundle

I can't login at all to follow the instructions. I am trying to install it and can't.


Hello @AnthonyF !

To clarify: You want to install OctoPrint to an existing OS on the Pi, yes?

If yes: What guide or script are you using?

No I was trying to install octopi (Stable) on its own since it was listed as an OS. I was using this video as a guide exactly:

I have now tried a third flash drive and am getting a new error. Its no longer giving me a panic error, after the four raspberry screen it just stops, the screen turns black, and nothing.

Just to be sure: did windows ask you to format the drive after you flashed it with the pi imager and did you click yes?

No I didn't flash the drive after installing the image. What I did was right click and eject it. I always format the drive BEFORE installing an image on it.

As far as I can tell the issue is, that the pi isn't able to access the second partition on the drive.
The kernel is located at the first partition. It loads it, starts booting and as soon as the kernel tries to load the OS it crashes.

Is it the first time you used that pi or did you use it via sd card before?

I have used the Pi before, loaded twister OS on that one. I want to stress though the flash drive is new. I thought the pi had no memory besides the drive you provide it. Am I wrong in this?

yes that's true - no internal flash memory.
However, it has a very small eeprom. It contains the bootloader configuration and a little firmware.

We could try to rewrite this configuration. Who knows, maybe it helps.
But let me first try to also boot my pi 4 with the stable image on a usb drive to make sure there is nothing else going on.

Well it works fine for me.
So let's try to rewrite the eeprom on your pi.

You need an sd card for this. First remove everything that is connected to the pi.
Open the Pi Imager, scroll down to Misc Utility Images, then Bootloader, then USB boot.
Flash that on the sd card, put it in the Pi, power it up, wait like 5 minutes, unplug it - done.

doing the eeprom rewrite, need to ask is there any visual update that its doing anything? I am seeing nothing on the screen is why I am asking.

no there is no output at all. just wait a few minutes.
In theory it's done in a few seconds. It's just to be safe.

I tried updating it again and this time I am actually getting prompts it says

Trying partition: 0
tba: 2048OEM: 'mkfs.fat' volume: ' noname '
rsc 32 fat-sectors 4033 c-count 516190 c-size 1 r-dir 2 r-sec 0
Firmware not found

Does this mean anything to you? To be clear this is the eeprom software.

Well it means that the firmware isn't on the card. I guess it just deletes the firmware after it was flashed. :person_shrugging:

The quickest and easiest way to get octoprint onto a Raspberry Pi microSD card is to use RPiImager, available here Raspberry Pi OS – Raspberry Pi for Windows, MacOS and Ubuntu, although the Ubuntu flavour will install anywhere a snap image is supported [I think].
It will install OctoPi by clicking on Choose OS > Scroll down to 'Other Specific-purpose OS' > '3D printing' > and OctoPi is presently second in the drop down list.

The RPi4 is the first Pi with an EEPROM, Pi3's have a one-time ability to change boot locations, you can find the utils and code here. Raspberry Pi Β· GitHub.
Apparently the EEPROM code is closed source (!).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.