"Failed to enable Bed Leveling" with M420 S1

What is the problem?

(I have BLTouch installed) When I use "M420 S1" to load a stored mesh instead of "G29" to auto level at the beginning and load the gcode in octoprint, it says the printer reported a problem "Failed to enable Bed Leveling". It happens exactly at the M420 S1.

What did you already try to solve it?

I made sure I have a stored mesh and saved it to the EEPROM via M500. I made sure to load it again with M501. I ran the gcode without octoprint through the Ender 3 SD-slot and it worked without a problem.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20211229143557.zip (197.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.7.2, OctoPi 18.0, Creality Ender 3 v1, Browser: Chrome, OS: Windows 11, Marlin 2.0 Firmware with BLTouch enabled. BLTouch SMART v3.1

It says 'Invalid mesh' when you are trying to load it. Something's either wrong with the EEPROM or the firmware trying to read it.

This is not something OctoPrint can impact, it needs to be fixed on your printer. It is calling itself 'Marlin 2.0.1', which is either quite old (and you could update it) or one from the manufacturer (if it is Creality, definitely update it)

The reason I suspect it looks like it 'works' from the SD card is because of different error handling, OctoPrint stops sending gcode when the firmware reports an error whereas the SD card prints just continue. So you have probably been printing without bed levelling enabled.

Try to keep the sd card in your printer.
For some reason creality saves the eeprom onto the sd card in some firmwares.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.