Failed to start Octopi webcam daemon service

Camera model
Raspberry Pi Camera Module V2-8

What is the problem?
The webcam server is currently not running

What did you already try to solve it?

rebooted, unplugged and re-plugged, reflashed, swapped connector ends, tried different ribbon connector

pi@octopi:~ $ vcgencmd get_camera
supported=1 detected=0

pi@octopi:~ $ /var/log/webcamd.log
-bash: /var/log/webcamd.log: No such file or directory

pi@octopi:~ $ raspistill -o cam.jpg
mmal: Cannot read camera info, keeping the defaults for OV5647
mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not detected. Please check carefully the camera module is installed correctly

pi@octopi:~ $ lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
Tried posting logs, says "new users can only post 2 links"

Additional information about your setup (OctoPrint version, OctoPi version, ...)

Raspberry 4
8 GB SDHC
Octoprint 1.3.12
Octopi 0.17.0

  • Is the CSI cable inserted the right way? The silvery contacts need to face away from the Ethernet connector!
  • Is the CSI cable fully seated?
  • Did you insert the CSI cable into the Display connector? It needs to be inserted into the CSI connector, which is the one closer to the Ethernet connector.
  • Is the other end of the CSI cable correctly attached to the camera board?
  • Is the camera activated in raspi-config?

Yes to all of the above. Sounds like I may have a DOA camera?

Might be. Wait a little - maybe someone alse got an idea

Try posting your log in a follow-up post.

Attached it

octoprint.log (49.3 KB)

I note that on my own (working) production rig, I have no /var/log/webcamd.log file either on a 1.4.0rc3 running on OctoPi 0.17.0.