Failing to create proper image?

What is the problem?

The image created for octopi by the imager doesn't work.

What did you already try to solve it?

Tried on known good Raspberry Pi 3 B+.
Tried a different sd card

Have you tried running in safe mode?

Not sure what that means.

Did running in safe mode solve the problem?

See above

Systeminfo Bundle

This is from the old Octoprint I am trying to replace / upgrade:

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.2 Safari/605.1.15
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1200.0
env.hardware.ram: 918192128
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.15.1
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 9.0.3
env.python.version: 2.7.13
env.python.virtualenv: True
octoprint.safe_mode: False
octoprint.version: 1.7.0rc2
systeminfo.generator: zipapi

Additional information about your setup

I was running Octoprint on Octopi before when my Anet A8 was working. I just got a new Neptune 2 printer an want to set up Octoprint again.

The old version runs, but it's way back level and seems to be missing stuff like the plugin manager.

I created a brand new card as directed on the Octoprint installation instructions. I double checked my wifi settings and they seem correct.

When I put the new sd card in the Pi it doesn't connect to WiFi. The same pi with the old card does.

As I said above the old system just doesn't look right

The old one is Octoprint Version 1.7.0rc2. Octopi is Version 0.15.1, running on Raspberry Pi 3 Model B Rev 1.2

It's been a while since I've used Octoprint, and I don't remember how to bring up the plugin manager and it's not obvious. Is it hiding somewhere.

Any suggestions on how to either troubleshoot the new card or safely update the new one would be gratefully appreciated.

Oops, I was only allowed one image upload and deleted the wrong one. Here's the Octoprint UI on the old system:

To diagnose booting/WiFi issues, it can help to connect the Pi using HDMI to a monitor/TV so you can directly access it and see if it is doing anything. Note that different software image would have a different IP address to the old one in most cases.

As for the older system, it looks OK to me. Open the settings (wrench in the navigation bar) and you should be able to find the plugin manager under there.

Charlie, thanks.

I mucked around with the old image trying to get rid of the obsolete Python message.

The instructions say to install the new octopi using the Raspberry Pi image utility, which is what I haven’t been able to make work. It then gave an alternative of running a python script to do the update. The first problem was I needed at least Python 3.5 to run the script, so ….

  1. I made a backup via the octoprint web ui, the I made a backup of the whole sd card volume using Disk Utility on my Mac

  2. I installed a bunch of development packages using apt-get.

  3. I got the python source code

  4. I did the old ./configure; make; sudo make altinstall dance

  5. tried to run the setup script, was told I needed to install some python package with pip

  6. tried to install that package , was told I should update pip.

  7. updated pip

  8. installed the package

  9. ran the setup script…

To be told that my version of octopi was incompatible with the script.

So I guess tomorrow I’ll need to borrow the display and keyboard from my Mac and hope that gives a clue as to what’s happening with the new image.

Yes, I haven't tested it with older versions of OctoPi and I set the limit because the Python version and system dependencies are not guaranteed to be up-to-date enough. I didn't expect anyone to go through all the steps to build Python from source on their Pi, if they could just install a new OctoPi image easier. To use the script you have to be on OctoPi 0.17.

If you have all the system dependencies installed, and you really want to use the script - note that I still really recommend installing the newer OctoPi image, 0.15 is kinda old, you could edit the version in /etc/octopi_version temporarily.

Other than that, we'll wait and see what plugging it in to a display can tell us.

Try connecting the RPI to a monitor and a network cable. Then you can verify it boots and SSH in a diagnose the WiFi etc


Thanks again. I hooked the HDMI up to the family room and it showed that it booted, showed it’s IP address and a login prompt.

It didn’t seem to be advertising octopi.local on Bonjour, but I could access it via the IP address and get to setup, After that it did show up on Bonjour.

I managed to then updated octopi to 0.18.

Next step is to take it back upstairs, connect it to the printer, and add some plugins.

In the meantime, I’ve been designing a pretty sweet enclosure for the Pi which wraps around the front left corner of the printer, hides the usb printer cable, and has a SD card slot for the printer using a microsd to sdcard adapter cable. And of course I’m planning to add a camera mount.