Fatal errors starting OctoPrint - several different errors

What is the problem?

I get the "Octoprint is currently not running" webpage when I try to access my printer. The log file says "name '_urllib_response_moved_attributes' is not defined", and when I rebooted, I get a new error of "bad marshal data (unknown type code)"

Is there any way to fix this, or should I just get a new SD card and start from scratch? Not sure if this is a failing card; I haven't tested the SD card yet.

What did you already try to solve it?

Reboot several times
Tried restarting the octoprint service

Have you tried running in safe mode?

no; can't even start octoprint

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I get the same fatal errors when trying to generate the dump from the commandline

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Pi4, running OctoPi 0.18.0 and OctoPrint 1.6.1

Seems like some kind of corruption to me - the only thing you can try and do is reinstall all of OctoPrint + dependencies, but I wouldn't hold out much hope.


~/oprint/bin/pip install --force-reinstall --no-cache-dir OctoPrint