Feature request: Option to upgrade Octoprint In Setup Wizard

I updated to 1.7.1 - but got some nagging about Python 2, so decided to bite the bullet and update my OctoPi from an older one (15 i think) to 18. Did a full backup first of course. When booting into 18 - i tried to restore my backup from within the Wizard - but was unable to because it seems Octopi has 1.5.x installed. Makes sense. I had to go through the motions of the whole wizard, and then, update Octopi, and then restore my backup. Not the end of the world - but it would have been oh so much more elegant if the Setup Wizard would have allowed me to update to the latest version there and then when it noticed my backup was taken on newer version than the installed :slight_smile:

Just a thought!


Hello @aris !

Please don't mix up OctoPrint and OctoPi:

I did a upgrade from OctoPi 0.17.0/OctoPrint 1.7.0 to OctoPi 0.18.0/OctoPrint 1.7.1 using the backup file I made before, loaded in the setup wizard (2nd step) and it worked fine.
Important is, not to unzip the backup file.

AFAIK, you should also can use OctoPrint 1.5.x backup files.

This feature was added in OctoPrint 1.7.0 but can of course not retroactively be applied to 1.5.x.

Additionally, the OctoPrint version shipped on the stable OctoPi release as available on the download page and from within the Raspberry Pi Imager tool is now also be kept up to date automatically. This was rolled out around two weeks ago.


@foosel interesting.

Here is what I did yesterday evening:

Updated my old octopi install (v 15 I think) with Octorpint 1.7.1 - all booted up fine but got the Python 2 nags.

Downloaded latest OctoPi image from here: GitHub - guysoft/OctoPi: Scripts to build OctoPi, a Raspberry PI distro for controlling 3D printers over the web
This downloaded a file called otcopi-buster-armhf-lite-0.18.0.zip

Imaged it to my SD card (using Balena Etcher on a mac)

Booted Pi with new SD

Connected to octopi.local (i'm wired, so no wifi config needed) and continued with the Wizard. It did not like my 1.7.1 backup - said it was too old.

I did all of this yesterday. I'm pretty certain it said I was on 1.5.x of Octoprint - but I could be mistaken. Could the image have been 1.7.0 - and not had time to catch up to 1.7.1 which I did my backup on? Or is OctoPi supposed download and install the latest Octoprint as part of its first boot?


The image in Guy's repo is the original build. The updated image is here: GitHub - OctoPrint/OctoPi-UpToDate: Latest OctoPi image with OctoPrint already updated to the latest release. And also linked on the official download page here: OctoPrint.org - Download & Setup OctoPrint.

And also available directly from the Raspberry Pi Image:


1 Like

@foosel right - I see where I went wrong - I didn't use the RPi Imager :slight_smile:

Interestingly though - when I click on the Download Octopi button at https://github.com/guysoft/OctoPi:


It links to:


I presume you control that host as it is in the octoprint.org domain - so maybe it should re-direct to the same image as what is available on the RPi imager which is "the latest"?

Guess what I've been up to the past two hours? ^^ Automating precisely that.


Fantastic! I must commend you on your attention to detail when it comes to the user experience. One of the best of any open source product I use. The only thing which comes remotely close in my experience is PiHole.

1 Like

Aha - a result. I now see that the link downloads:

octopi-018.0-1.7.1.zip :+1:t2:

Yep, and it will also switch to new releases within 15min.

1 Like

I had a very similar issue where it seen the version i had installed as newer and had to do the same. think in my case there was an update to octopi but the version of octoprint that it used was seen as older because i updated to a release candidate of octoprint but the octoprint version included with the newer octopi was an official release so appeared older.