What is the difference between OctoPrint and OctoPi? Are they the same thing?

No, OctoPrint and OctoPi are not the same thing.

OctoPrint is a fully featured print server/web interface for 3D printers, written in Python and HTML/JS. It is platform agnostic and runs basically everywhere where you can install Python (the full version, not Micropython), be it a cheap single PCB computer like the Raspberry Pi running Linux, a fully featured gaming PC running Windows, a Mac running MacOSX or a server running some BSD flavor. It was created and is actively maintained by Gina Häußge aka @foosel.

OctoPi on the other hand is a preconfigured image for the Raspberry Pi. It is based on the Raspbian Lite image by the Raspberry Pi Foundation and bundles OctoPrint plus mjpg-streamer as a webcam server plus a couple of scripts to make your life easier and allow for easy initial setup. This image is probably the most common form of running OctoPrint. It was created and is actively maintained by Guy Sheffer aka @guysoft.

Think of it this way: OctoPi is more or less the operating system, OctoPrint is the main application that runs on it and actually talks to your printer.

Current versions:

Will PrusaPrint work with an external raspberry pi on a prusa i3 MK3
Raspberry pi 3 model a+
New OctoPi Release: 0.16.0
OctoPi WiFi/network connection troubleshooting megatopic
OctoPrint failing to update to 1.3.10
Setting up OctoPrint on Windows
Pi 3 model B unable to connect to WIFI
SOLVED: Tracking down issue with Pi4/0.17
Does OctoPrint work with Raspberry Pi 3B (Not +)
OctoPrint with PiCam V2
Raspian and Octoprint together on USB storage device
ERROR: tornado.access - WARNING - 404 GET /currentsetting.htm
Setup icons have disappeared
Flash always fail
Can't connect to OctoPrint
Webcam On-Off Option
Touch UI - Can't Login
Issues with fresh install unable to access options
OctoPi Release Candidate 0.18.0rc1 Install
I'm lost! Can't do jack!
OctoPi not printing
[SOLVED] Did Octoprint just crashed my SD?
Octoprint on a pi4 8gb
Octopi server not working
Automating OctoPrint's release tests
Octoprint destroys sd card after update
Temperature reporting now working with new ender 3 V2
Raspberry Pi HQ Camera
Can't access control.htm
Octolapse installation fails (Pillow)
Filament Run Out sensor not working
Setting system clock
Makerbot Replicator x2
OctoPi build now supports docker
New OctoPi Release: 0.17.0
Network setup changed, cannot login to Octoprint
Ignoring Start GCode
PiHole on top of Octoprint
OctoPi WiFi/network connection troubleshooting megatopic
TAZ Octopie some questions
How can I find out what Python version OctoPrint is running under? On the command line it still reports version 2.7!
Webcam not accessible from OctoPi
Network ports required for OctoPrint?
Can octoprint os runs on odroid C2?
Python version 2.7.16 aftert fresh install 1.8
Target Temp changes without instruction to do so
Pi Camera on Raspberry PI 4 works in terminal but not in octoprint
Feature request: Option to upgrade Octoprint In Setup Wizard
Can Octopi cool down Prusa i3MK3S+ remotely?
Can I access octoprint from my Mac
Setting up OctoPrint on VirtualBox on WIn10
Octoprint disconnect - Firmware error - BLTouch

As I’m sure you know, Home Assistant has this same problem. Home Assistant was the actual software. Then they have HassOS which is the OS that runs on a Pi. Then they have Hassio which is Home Assistant and its addons running as Docker containers.

And the icing on top is that they literally just renamed Home Assistant into Home Assistant Core and Hassio into Home Assistant.

Super confusing.

Hopefully OP doesn’t need to go through anything like that.