Filament change not working

What is the problem?

Using Prusa Slicer adding a filament change at a certain height. Was working with Octoprint 0.17.1RC1 but not with RC2.

If I print from Octoprint, when the Filament Change command is sent to the printer, the printhead goes to the park position and lets me change the filament. Upon restarting the print, the printhead positions itself where it left off but the printer just stays there and does nothing with no messages in the console screen.

What did you already try to solve it?

When printing the exact same GCODE from tthe printers SD card everithing works as expected.

The same GCODE was working with Octoprint 1.7.0 RC1. The problem started occuring after I installed 1.7.0 RC2.

No other software modifications performed on Octoprint other then installing RC2. No change on the printer firmware was done.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (66.6 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Firmware Marlin 2.0.3

Hi :slight_smile:

Could you please enable serial logging, run a testprint with filament change and upload the serial.log or the systeminfo bundle afterwards?
Otherwise we can't see what happened :slight_smile:


Just tried to print a 10 mm cube with a filament change @ 5 mm. Machine paused and let me change the filament but when I tried to start the print the nozzle positioned itself at the right place on the cube but remained there without doing anything else. At that point the only thing I could do was to disconnect the printer and reset it. I have attached the requesterd log files. Hope this helps. (49.5 KB)
serial.log (245.6 KB)

Did you resume the print in OctoPrint? It shows as paused in that log file. Though there is a gap before the printer was disconnected with no communication at all.

I remember that there was an issue with filament change on some earlier Marlin 2.0.x versions, where they would hang and not do anything. Have you thought about trying to update the firmware to something newer?

On this attempt I did it from the printer LCD screen. I have also tried it in the past from OctoPrint with basically the same result. What is strange is that it wasn't doing it with RC1.