πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Filament Detection Sensor & motherboard v 4.2.2

What is the problem?

Installed a Creativity 3D Printer Filament Sendor module. Doesn't seem to work.

WRITE HERE
The Ender 3 Pro motherboard has a connection for the sensor, but I do not have the skills needed to modify the operating system (Marlin 2.0.8.2) to get it to work.

ALSO tried connecting it to three GPIOs on my OctoPrint Pi, but that also did not work. Used GPIO 17 for the red wire, 18 for the white wire, and 20 for the black wire from the sensor. Not sure the pin to wire colot is connect.
Also added "Plugins:", (2 spaces) Filament:, (4 spaces) Pin 17, (4 spaces) bounce: 00, each on their own line, to config.txt. Also tried to install the OctoPrint Filament Plug-Ins, but it always fails.

What did you already try to solve it?

WRITE HERE
Installed sensor to motherboard, then a second time tried connection to OctoPrint Pi 3b.

Have you tried running in safe mode?

WRITE HERE
Have not tried safe mode, not sure that would help

Did running in safe mode solve the problem?

WRITE HERE
No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE
OctoPrint v1.7.3 on a Pi3b
Printer is an Ender 3 Pro, version Marlin 2.0.8.2.

octoprint-systeminfo-20220616203001.zip (3.5 MB)

So you connected :face_with_raised_eyebrow:

  • Red to pin 17 of the pin header -> 3.3V
  • Black to pin 20 of the pin header -> GND
  • White to pin 18 of the pin header -> GPIO 24

Referring to your log, you need a filament runout plugin for OctoPrint

But not that for the OrangePi

Where did you get that from?

How did you try to install

The original instructions I was following came from www.all3dp.com. Today I found a much more indepth article at Filament Manager Plugin: How to setup postgresql database - Docs - OctoPrint Community Forum. Followed it without issue, except the sensor is not working. But I did notice there was no Red or Green LED in the sensor so I'm thinking I blew it up trying to get it to work. Ordered a new one, should get here Friday, then we will see.

As for the GPIO's, I used pin 9 for ground (black wire), pin 17 for 3.3vdc (red), and pin 18 (GPIO 24) for white.

Thanks!

Is it made to run on 3.3V or 5V