Filament Runout Sensor with Octoprint for Windows 10

What is the problem?

Is it possible to use a runout filament sensor using Octoprint running on Windows 10? I am using a Crealtiy Ender 5 Pro with the 4.2.2 board and the sensor plugged into the dedicated runout port.

Thank you.

What did you already try to solve it?

Searched online

Have you tried running in safe mode?

WRITE HERE

Did running in safe mode solve the problem?

N/A

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Creality Ender 5 Pro with 4.2.2 board with dedicated runout filament sensor port.

Enable HOST_ACTION_COMMANDS and HOST_PROMPT_SUPPORT and you should be good to go with the runout sensor. This means that the printer will tell OctoPrint to pause the print.

Thank you Charlie for the quick reply. I am new to 3d printing and haven't installed Octoprint before so wanted to make sure it was doable before I repurposed and old Windows 10 machine. Thanks again.

1 Like

Sorry to ask. But where are these settings. I have looked and cannot see them
Thanks inadvance

You can find them in the Marlin firmware in the file Configuration_adv.h

Thanks for the reply, but a real newbie to all this and sorry to say it is a bit beyond me at the moment.
So any screen shits etc would be really appreciated

What printer do you use?
Maybe there is a ready to user firmware with that setting enabled.

I have a Ender 5 Plus. with a filament senor. But it seems to be not functional know i am using Octoprint

You can find information on Ender 5 firmware here:

and a firmware here:

so i am a little lost now. The initial direction was to enable the HOST_ACTION_COMMANDS and `HOST_PROMPT_SUPPORT and now to edit the firmware,
Isn't Octoprint the area i need to focus on?

Yes, sure, but the firmware has to support it.

it is the latest firmware.

Please go to the OctoPrint Terminal and type in:

M115

and post the result.

OctoPrint automatically supports filament sensors connected to the printer if the firmware of the printer is going to communicate pausing the print to OctoPrint. The HOST_ACTION_COMMANDS and HOST_PROMPT_SUPPORT options are both options in Marlin Firmware, not OctoPrint.

Most stock firmware provided by the manufacturer of the printer does not enable this, so you have to build your own or use some 3rd party firmware.