Filament (tool0) missing from state

Simplify3D 4.1.2
Octoprint 1.4.2.

On most prints i'm missing the Filament (tool0): .....meters information.

Different slicer profiles.

The strange thing is, I have this with al new uploads to Octoprint. First they won't show the Filament(tool0): information. When I print the file for a second time the information mostly shows (not always). What often also seems to help is to load and close the print gcode a few times. I really don't have a clue what could be the reason.

Below the last file I've tested

Nvidia_Shield_Stand_2015-PETG_Eryone.gcode (2.1 MB)

Hope someone has a clue why this is happening.

Simplify3D by default puts the filament usage information at the end of the .gcode file:

; Build Summary
;   Build time: 0 hours 3 minutes
;   Filament length: 22.8 mm (0.02 m)
;   Plastic volume: 145.21 mm^3 (0.15 cc)
;   Plastic weight: 0.18 g (0.00 lb)
;   Material cost: 0.01

CuraLE (LulzBot Edition) and Ultimaker Cura put it at the beginning:

;Generated by Cura LulzBot Edition GCodeWriter Version: 3.6.22
;FLAVOR:Marlin
;TIME:128
;Filament used: 0.0274493m
;Layer height: 0.25
;Generated with Cura_SteamEngine 3.6.22

I believe OctoPrint finds these statistics (eventually) and updates its metadata for the file.

You could prove (or disprove) this theory by editing the gcode file and moving the comments at the end to the beginning of the S3D gcode file. Rather that do that manually each time, see https://forum.simplify3d.com/viewtopic.php?f=8&t=13066 for adding to the top of the gcode output. Searching their forums for "build summary" will find other interesting tidbits.

Thanks. I've tried that but unfortunatly it didn't work. I've also tried to copy the information from a working gcode also without succes.

When I compare a working and a non working gcode and can't find any significant changes. i've attached 2 gcode files (removed gcode lines) notworking.gcode (7.0 KB) working.gcode (7.0 KB)

Am I overlooking something?

The only thing I see is that working has an extra blank line at the end.

So small gcode files show up and large don't?

That was a good one, but just looked and it's on small and on big files.

I've attached a strange one, some Gcode files i've uploaded yesterday. These are two identical Gcode files, one shows the filament usage and one don't. Had to remove the gcode lines because the file was to big. So it doesn't seem to be the gcode file and has to be something strange with octoprint?

Google_Home_Mini_Outlet_Mount-PLA.gcode (7.4 KB) Google_Home_Mini_Outlet_Mount-PLA.gcode (7.4 KB)

I tried here and both show up after a few moments.

Have you tried safe mode?