File upload doesn't open file browser

What is the problem?

File upload button does not open a file browser so that the user can select a file to print

What did you already try to solve it?

The problem started when I upgraded my OS to Ubuntu 22.04.1 LTS. the following is the output from lsb_release -a:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.1 LTS
Release: 22.04
Codename: jammy

I reinstalled the operating system on the pi. I used Raspberry Pi Imager v1.7.2. I am using a 16GB SD card.

Have you tried running in safe mode?

Yes, I started OctoPrint in safe mode and the problem still exists.

Did running in safe mode solve the problem?

no

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
browser.user_agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Firefox/102.0
connectivity.connection_check: 1.1.1.1:53
connectivity.connection_ok: true
connectivity.enabled: false
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 914006016
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.octopiuptodate_build: 0.18.0-1.8.2-20220816135025
env.plugins.pi_support.throttle_check_enabled: true
env.plugins.pi_support.throttle_check_functional: true
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.last_safe_mode.date: 2022-08-28T17:06:08Z
octoprint.last_safe_mode.reason: settings
octoprint.safe_mode: false
octoprint.version: 1.8.2
printer.firmware: Marlin E3V2-Extensible-UI (Jun 6 2021 13:54:38)
systeminfo.generated: 2022-08-28T17:16:43Z
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
I have used OctoPrint for a few years and have never ran across this problem before. It almost acts like a permissions problem, but, I do not know where to start to troubleshoot. Thank you.

A short hint:

thank you for the info. I tried to download the file and it does not let me. This made me wonder if it is an issue with the browser, so I installed chromium and now everything works. So it looks like it is a problem with FireFox.

2 Likes