File upload freezes and won't refresh the list

What is the problem?

After updating to 1.5.2 when a file is uploaded it will freeze and not refresh the file list. Also when deleting a file.

What did you already try to solve it?

I found restarting or rebooting works to refresh the list but that gets annoying to have to restart every time a file is uploaded.

Have you tried running in safe mode and if so did it solve the issue?

Have not tried safe mode yet as I have prints going.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

will post log when prints are complete

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.5.2 On a Cr10s running marlin on a windows 10 system

I am experiencing the same problem. The file seems to upload but the "Saving" indicator changes to "Refreshing file list" and never goes back to normal until Octoprint is restarted. The problem does not occur while running in Safe Mode.

Hello @Doug_Leary

So one of the plugins you have installed is the culprit.
For we don't know what plugins these are, you may have to disable one by one to find out.
It may be an old version of Gcode Editor.


I had the same problem and disabling GCode Editor plugin solved the issue as well.

1 Like

Thanks. Gcode editor was the culprit

1 Like