Files are not shown after restart

What is the problem?
When I start Octoprint the files on the left side are not displayed. I talked also with jneilliii I we found that the files are shown when octoprint is started in safemode. When I then start octoprint again in normal mode the files stay displayed.

After a restart of th raspberry the files are again not shown.
There are NO Plugins installed!

In the logs are Error 500 (tornado.access - ERROR - 500 GET /api/files?recursive=true (::ffff: 47.76ms)

If I connect via SSH, the files are in the upload dir.

I set up a completly new SD-Card without plugins. => same problem.

I'm running Octoprint 1.4.0 with OctoPi 0.17.0 on a Raspberry 3 B+. Using actual Firefox on Windows 10.
Printer is a CR-20 Pro. But i think it has nothing to do with the printer.

octoprint.log-1.log (12.9 KB)


Try to disable the javascript bundle/minify feature. Sometimes then you will receive more information if its a UI-Issue


        bundle: false
        minify: false

Hi Olli,
I added the minify: false to the config.yaml. Now it looks like my file browers works fine after each startup.

Can the minify option stay disabled?

To answer your question, yes you can leave that disabled. You may want to open an official issue on the OctoPrint github repository to see if this might be a larger problem.

Sorry, this was not the solutions...

After some restart tests I have the issue again. Actually I can't find a reason and I can't reproduce it safely.

Just curious if you've tried another browser or not?

When the files are not shown, this is on both of my browsers (Firefox & Chrome) the same behavior.

But Chrome shows in the console then:
GET 500 (INTERNAL SERVER ERROR) jquery.js:9600

In Forefox this Error is not shown, but in the log file.

I just take a new SD-Card (for the 3rd time) and setup up the Octopi buster lite image. I went through the setup pages and after that I uploaded a file.

Then I start to print the file. After that the files was not shown anymore. And because of that, the printjob can't stopped or paused.

How can this be? I used Octoprint serveral weeks without problems and now every SD-Card have the same error? And I am the only one with this problem? Very very strange ...

Edit: Attached teh log-file

octoprint2.log (79.1 KB)

Do you have the hide after successful print checked in the file list?

No, i didn‘t.
Folders are also not visible.

Yep, log full of errors. You might want to open an issue, making sure to fill out the template completely and provide full octoprint log. It appears to be json related on the get files call, which makes sense based on the issue you're having. Did you restore a backup or anything after the initial setup, or possibly the specific gcode files your uploading/testing with are causing issues.

Can you please share the GCODE file you uploaded that made stuff break? This sounds suspiciously like

Sorry, today I was very busy. i will check your hints tomorrow.

When I read the other post, a gcode file could be the problem also in my issue.

I don‘t use a backup. The system is completly in the configuration after the install process.

More information tomorrow...

Short update:

I just have a look via my iPad and SSH to the metadata.json and I also have a entry with "estimatedPrintTime": NaN.

I will provide the gcode file tomorrow!

Now, here is the gcode file I uploaded and which has the NaN in the metadata.json:

Wandhalter_V1_20-60.gcode (1.4 MB)
The file is generated by Cura. The only thing I added in Cura is the command "G20 ;Auto Bed Leveling" in the start G-Code. Can this be a problem?

And here is a Screenshot of the metadata.json:

Edit: Also the height atribute is "Inifinity".

I added some numbers for he height and estimatedtime in the metadata.json. after restart octoprint the file was shown...

Well, if you'd print out "Buzz" the error would be clear, but you are printing a "boring" Wandhalter...or is it for "The Great Wall of China" :wink:

I think I solved the problem!

I added in Cura the startcode G20, because I wanted to level the bed. But the command was wrong! G29 is for bed leveling. G20 is to set the unit to inches. That's why the metadata file was wrong!

I deleted the G20 code and now the metafile shows correct values!

Thanks for your help! Without your hints I found the mistake!

1 Like