Finding usb printer on Ubuntu desktop

What is the problem?

I am trying to setup Octoprint 1.4 on my Ubuntu 20.04 desktop to use with a Monoprice Maker Select V2. The computer system is setup to dual boot, and I've gotten the printer to run using and older copy of Cura through Windows 10, and in that environment, the printer shows up on COM3, so I believe that the printer is functioning, and the USB connection is valid.
On the Linux side, the printer shows up as ttyUSB0 (UART id), but I am unable to get Octoprint to connect to the printer.

error msg excerpt:
could not open port /dev/ttyUSB0: [Errno 13] Permission denied: '/dev/ttyUSB0'

What did you already try to solve it?

Tried setting the Octoprint serial port value to AUTO
Tried setting the Octoprint serial port value to "manual" dev/ttyUSB0
Placed my Linux user in the dialout and tty groups
Set udev rule to set permissions for ttyUSB0 to 666 (read/write by everyone)
Reboot both Octoprint, then OS

Have you tried running in safe mode?

No - don't see a menu option for either shutting down, or restarting Octoprint.

Did running in safe mode solve the problem?


Complete Logs (error message from terminal)

Connecting to: /dev/ttyUSB0
Changing monitoring state from "Offline" to "Error: Connection error, see Terminal tab"
Unexpected error while connecting to serial port: /dev/ttyUSB0 SerialException: '[Errno 13] could not open port /dev/ttyUSB0: [Errno 13] Permission denied: '/dev/ttyUSB0'' @ (hook default)

Thanks in advance.


Adjust rights of the account Octoprint is using by putting it into a group, that is allowed to open dev/ttyUSB0

1 Like

I believe I have done that when I made my account a member of tty and of dialout. Any reason I shouldn't have access? Thanks.