Firmware Update Plugin Errors with firmare.hex file

What is the problem?

Using "Autobuild" in VSCode I have previously built a firmware.elf file in .pio/build/mega2560 which flashes with the Octoprint Firmware Updater Plugin without error on my Pi with a RAMPS 1.4 EFB board mounted on a Mega 2560 Arduino.

Using the same environment it NOW builds a firmware.hex file which errors.(see log files below.

Same Marlin Configuration.h file on all occasions

What did you already try to solve it?

Tried removing serial cable, pressing reset and reconnecting but no cigar. Don't know what else to try! Excuse my ignorance.

Have you tried running in safe mode?

No because as I understand it this will disable plugins.

Did running in safe mode solve the problem?

Not tried for reasons above.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (246.6 KB)

Additional information about your setup

OctoPrint version 1.7.3, Pi Model B v1.2 , printer, Marlin firmware, browser Google/Edge, Windows 10 operating system, ... as much data as possible

You are aware that OctoPi 1.0.0 is release candidate?
Have you tried with the latest stable OctoPi 0.18.0?

Pulling the plug to reset the Pi does not make it better. It can cause filesystem issues.

In addition, your printer has a hominh issue:

2022-03-16 19:33:39,714 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Printer halted. kill() called!
| Last lines in terminal:
| Recv:  T:25.34 /0.00 B:26.59 /0.00 @:0 B@:0
| Recv:  T:25.41 /0.00 B:26.59 /0.00 @:0 B@:0
| Recv:  T:25.22 /0.00 B:26.62 /0.00 @:0 B@:0
| Recv:  T:25.37 /0.00 B:26.81 /0.00 @:0 B@:0
| Recv:  T:25.44 /0.00 B:26.81 /0.00 @:0 B@:0
| Recv:  T:25.22 /0.00 B:26.53 /0.00 @:0 B@:0
| Recv:  T:25.47 /0.00 B:26.87 /0.00 @:0 B@:0
| Recv:  T:25.16 /0.00 B:26.81 /0.00 @:0 B@:0
| Recv:  T:25.44 /0.00 B:26.56 /0.00 @:0 B@:0
| Send: G91
| Recv: ok
| Send: G28 X0 Y0
| Recv:  T:24.66 /0.00 B:26.37 /0.00 @:0 B@:0
| Recv: echo:busy: processing
| Printer seems to support the busy protocol, will adjust timeouts and set busy interval accordingly
| Recv:  T:24.87 /0.00 B:27.56 /0.00 @:0 B@:0
| Recv: echo:busy: processing
| Recv:  T:26.16 /0.00 B:26.94 /0.00 @:0 B@:0
| Recv: echo:Homing Failed
| Recv: Error:Printer halted. kill() called!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.