Firmware with Host Action Commands for Ender 3 S1 Plus

What is the problem?

I need a firmware for my Creality Ender 3 S1 Plus that has Host actions enabled because I dont know how to compile it myself

What did you already try to solve it?

Tried compiling but only get errors

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

I have the newest Version of Octoprint running on my Pi 4b which is connected to my printer via usb cable. I found the original Firmware from Creality but there seems to be Host Action disabled.


Hi :slight_smile:

Building your own firmware isn't hard, but I guess it takes some time the first time.
There are different guides on yt on how to do it - here's one that seems ok (didn't watch the whole thing and just skipped through)

Now to the example configs for your printer.

and here's a guide on how to flash the display

I tried building my own firmware but the Marlin build always fails. Funny thing is everything is fresh installed and I have quite allot of experience with VS Code but still cant make any sense of the build errors I get.

Why does it fail?

Also I just looked what motherboard version I have and the only number I can find is CR4NS200141C13, which is supposed to be an Ender 5 Board and not ender 3 now I am finally completly confused

I got it to build now, but now I have the next problem of if my touchscreen is going to work and what i described below

Did it work? Have a Sprite Pro I want to throw on but waiting until it's confirmed firmware will work with the LCD

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.