Freenove touchscreen not working

What is the problem?

I am using a freenove touchscreen, and i am trying to connect it to octoprint using touchui, but it keeps booting on black

What did you already try to solve it?

I tried to update it, and i tried to search up ways to fix it, but nothing works.

Additional information about your setup

What kind of hardware precisely, OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

As i said before, it is freenove touchscreen, and the 3d printer is the flsun super racer.

Hello @regentstew !

You did not mention:

And also the systeminfo bundle is missing too. Please attach that file to your next post.

octoprint version 1.10.1
octopi version: Build 2024.04.25.094544 with "webcamd", based on OctoPi 1.0.0, running on Raspberry Pi 4 Model B Rev 1.5
I have the systeminfo bundle attached. (124.9 KB)

ok, i sent the info

also, its no longer a black screen, it randomly today turned white when i turned on my raspberry pi (idk if that changes anything)