Frequent disconnect, print fails half way though

What is the problem?
Almost every print I attempt fails midway through. The raspberry Pi seems to lose connection to the printer.

What did you already try to solve it?
I've tried multiple power supplies. One made for the Pi, multiple cell phone bricks, and one iPad brick that has a higher output.


octoprint 4.log (402.0 KB)

I've tried quite a few different mini-usb cables and power supplies. Despite that I do have new cables coming tomorrow from Amazon just to be safe. I just find it hard to believe that I have that many bad cables.

Hello @ASMills85!

Please share the logs!

1 Like

It's there. It's hidden under "summary" for whatever reason. Thank you!

1 Like

I see, thank you

Ok, first this:

2020-02-17 04:01:53,747 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

You may check your power supply and also the cable.

And this:

2020-02-17 04:29:40,033 - octoprint.util.comm - ERROR - Please see for possible reasons of this.

This is multiple times. Please also share the serial.log.

This does not look good:

2020-02-17 05:51:14,126 - tornado.access - WARNING - 409 GET /api/printer/bed (fe80::cca:e96f:402a:dfd) 8.22ms
2020-02-17 05:28:04,611 - octoprint.startup - INFO - ******************************************************************************

There is no shutdown sequence before the startup. Also multiple times. Have you pulled the power plug?

Shuold look like this:

2020-02-18 18:46:01,143 - octoprint.server - INFO - Shutting down...
2020-02-18 18:46:01,917 - - INFO - Processing shutdown event, this will be our last event
2020-02-18 18:46:01,923 - - INFO - Event loop shut down
2020-02-18 18:46:01,945 - octoprint.server - INFO - Goodbye!
2020-02-18 18:46:04,642 - octoprint.startup - INFO - ******************************************************************************
2020-02-18 18:46:04,645 - octoprint.startup - INFO - Starting OctoPrint 1.3.12
1 Like

I'm sure I've pulled the plug without shutting it down while testing the different power supplies. Assuming that corrupted something, is a reflash the only way to fix that?

Attached is the serial log, thanks again.

I also have the new cables and am doing a short test print.

serial.log (354.0 KB)

You may be lucky with the pulled plug and nothing happened so far.
I suggest to check the cable from the Pi to the printer. As long as necessary and best quality as possible.

But you may also update the printer firmware:

2020-02-19 15:03:00,457 - !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
2020-02-19 15:03:00,458 - Your printer's firmware is known to lack mandatory safety features (e.g.
2020-02-19 15:03:00,458 - thermal runaway protection). This is a fire risk.
2020-02-19 15:03:00,458 - 
2020-02-19 15:03:00,461 - Learn more at
2020-02-19 15:03:00,464 - !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
1 Like

I've been able to print two prints without it failing with the new cables. I'm going to give it another day or so before I consider it actually fixed. It looks like it was the cables even though I tried multiple ones. The new ones seem to have done the trick. Thank you for your help and I'll keep it updated.

1 Like

I think we’re going to call this solved. I’ve since run into random underextrusion issues, so I’m still fighting with my printer. I have new nozzles arriving tonight.

The new power and new serial cable between the two seems to have fixed my disconnect issues. I’ve been able to do 30 or so hours of printing without issue.

Thank you so much for your help!