Fresh Install of Octoprint & Octoscreen not working

What is the problem?

Installing on an Ender 3 Pro (new printer)
I installed a fresh copy of Octoprint using the RaspberryPi Imager. Once completed, I went and downloaded the latest Octoscreen. Nothing showed any errors. This was on a brand new Raspberry Pi 4B with 4GB RAM and using a 7" touch screen. No errors of any kind during the installation. After the Octoscreen install and a reboot, the picture shows where it sits. Any help would be greatly appreciated. Thank you, Paul.

What did you already try to solve it?

I have tried 7 USB cables and 2 Raspberry Pi's with no resolution. I've even tried to reinstall 3 additional times and it keeps getting hung on the same location. I tried connecting the printer to USB using Cura and it connected fine and printed a 20x20x20 cube. I can SSH into it with no issues.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Have you setup & used OctoPrint through the web UI for any printing before installing OctoScreen?

Hi Charlie, boy do I feel dumb. Thank you for responding. As soon as I read web UI, I proceeded to call myself a few choice words. I completely forgot about that portion of the setup. Thank you for your help! It is up and working now.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.