Frustation with Octoprint

Hi guys,

This is my first post and probably the last.

I writing this to share my frustration and alert new users that may are considering buy a raspeberrypi to run their printers.

I believe the ideia of octoprint is brilliant, be able to control your printer via wi-fi is something that everybody wants to do, but be aware that it is not simple and straight forward.

After spend almost 70 euro to get the hardware needed to install octoprint on my Prusa Mk3, I become very frustrate to see that I have wasted my money and time trying to have this feature on my printer.

Read many threads and watched many tutorials, got it working perfect but the down side is that I cant turn my printer/raspeberrypi off because when I turn on again I cant open the octopi.local on my browser, checked my router and the raspberrypi is connected to my network but wont open even if I type the ip address on browser, so I have tried everything and the only solution is to take the sd card and reflash the firmware, so it is really frustrating to see that there is no explanation for such problem, and no direct answer for that problem and no way to find the problem.

So for those that wondering buy a raspberrypi to use octoprint, be aware that you could be wasting money and time, also being frustrate for the lack of support.

Hello @juliogdiana!

Sorry, what lack of support?

This is your first post here, you never came with your problem to us to help you. Instead you blame the people because they haven't the same issue you have. Some issues are common, some are very unique.

So you may open a new thread in Get Help and explain what your problem is and provide the information that there are asked for. The chances to solve your problem are much higher then.


This is hilarious, turning up on the community forums to say there is no support :rofl:


I would venture to guess that you probably went against recommendations and shoved a pi zero w into your MK3 as described by the prusa forums,docs etc. If that is the case, then your whole problem should be directed at PrusaReseach because it has been told to them several times, even recently on twitter that a pi zero w is not sufficient enough a machine to run octoprint on. And if you connected it the way recommended by PrusaReseach then when you power off your printer you are corrupting your SD card on the pi because of not properly shutting down. If you don't shutdown octoprint from the system menu then you are unintentionally corupting your SD card and the OS that runs on the pi.

If that's not the case, then I apologize for this assumption, and would like to welcome you to the forum where you can Get Help and also point out that there is a support-octoprint channel on Discord as well..

1 Like

pi 4 I have, as I said, I did everything that should be done.

Community is different from support, all I see here is people with unsolved problems.

And a bunch of people trying to solve those problems. Your profile says you have only read 2 mins here - carry on reading. Unless you ask for help, then your problems will not be solved.

There's loads of topics solved, but I'm pretty sure with this kind of response yours won't be one of them. Here's some evidence of solving people's problems:

I'll give you another chance to create a post with some specific problems (we do need more than 'it doesn't work', not mind readers) but I'm not feeling inclined to respond at the moment.

1 Like

I have read this forum a lot on last 30 days trying to get the octoprint to work, I just create the profile now to post my frustration.

Support costs money, community driven help is going to be all you get for a free software solution that works for ~100,000 other people. Take it or leave it, but as many have already mentioned not asking for help with details as to the problem and then just dropping in to complain about the product doesn't do anyone any good.

1 Like

fixed that for you...


You have been pointed to where to get help. If the only reason you open an account here is to vent and do a "buyers beware" for a free product, that's not what this place is for.

Closing this since everything has been said and we don't need this to escalate.