G1 Z0 not works in octoprint


After i do a G28 home machine performes home and goes X10 Y10 Z10, then if i do a G1 Z0 nothing happens, why machine not move?


You need to tell us (a lot) more about your configuration. Until Gina gets the information posted here, please read https://github.com/foosel/OctoPrint/blob/master/CONTRIBUTING.md#how-to-file-a-bug-report and answer as many of the questions as you can.


make sure the machine is in absolute mode, if it's in relative mode then G1 Z0 will do precisely nothing (because you're telling it not to move).

See G90 and G91 http://reprap.org/wiki/G-code#G90:_Set_to_Absolute_Positioning

Send it

G1 Z0

and see if that works, your printer may default to relative mode (assumptions ahoy because you've left out a bunch of vital info)

Also if the machine is at Z10 and the limit switch (perhaps in the form of an inductive probe?) has been triggered, your firmware will probably prevent it from moving any further, you'd need to configure your firmware to either allow movement when triggered, or tell it it's allowed to move a further 10mm down (how you'd do that depends on your firmware, again, no info provided).


With other softwares this dont happens, i did before the G90 , G1 Z0 and same result, ill give it a new test later when i get home and let you know results


When you run your next test, enable the serial log in octoprint's settings, and post it up on pastebin. Then we can see the communication between octoprint and your printer. If possible, maybe also use another program that works and has some sort of serial logging (or at the very least copy the terminal output) and paste both to compare.


got it to work but i get this error on terminal

Recv: echo:EEPROM version mismatch (EEPROM=? Marlin=V53)
Recv: echo:Hardcoded Default Settings Loaded


From comments you have posted here, you can send commands to your printer, correct?
If yes, then send "M500". That should clear up your error.


on conection i get this

Changing monitoring state from 'Error: EEPROM datasize error.
' to 'Offline'
Changing monitoring state from 'Offline' to 'Detecting serial port'
Serial port list: ['/dev/ttyACM0']
Connecting to: /dev/ttyACM0
Changing monitoring state from 'Detecting serial port' to 'Opening serial port'
Connected to: Serial<id=0xb01a4bf0, open=True>(port='/dev/ttyACM0', baudrate=250000, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from 'Opening serial port' to 'Connecting'
Send: N0 M110 N0*125
Recv: echo:Unknown command: ""
Recv: ok
Changing monitoring state from 'Connecting' to 'Operational'
Send: N1 M105*38
Recv: echo:Unknown command: ""
Recv: ok
Send: N0 M110 N0*125
Recv: ok
Send: N1 M115*39
Recv: FIRMWARE_NAME:Marlin bugfix-1.1.x (Github) SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:X-Engrave EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
Recv: Cap:EEPROM:1
Recv: Cap:PROGRESS:0
Recv: Cap:PRINT_JOB:1
Recv: Cap:Z_PROBE:1
Recv: ok
Send: M21
Recv: echo:SD init fail
Recv: ok
Send: M155 S2
Recv: ok
Recv:  T:17.14 /0.00 B:16.87 /0.00 @:0 B@:0
Connection closed, closing down monitor

i did that startup send M502 to get sets from arduino
M500 save data but when i send the command M501 i get this

Send: M501
Recv: Error:EEPROM datasize error.
Changing monitoring state from 'Operational' to 'Error: EEPROM datasize error.
Recv: echo:Index: 629 Size: 651
Recv: Unified Bed Leveling System v1.01 inactive.
Recv: echo:Hardcoded Default Settings Loaded
Recv: ok

octoprint popup panel tell me:

Unhandled communication error
There was an unhandled error while talking to the printer. Due to that OctoPrint disconnected. Error: EEPROM datasize error.


@vMeph I fixed your formatting. Please enclose logs of any kind in ``` code fences or alternatively use the toolbar button:



ok @foosel will do it
it seems this error is a bug on marlin version bugfix they trying to solve it....