G4 times out even though it is set as a "long running command"

What is the problem?

Using a G4 command over about a minute causes the machine to shut down due to a communication error. I already have G4 in "Long running commands" under Settings > Serial Connection > Firmware & protocol. I also have "Actively pause communication during G4 dwell command (Repetier)" checked.

What did you already try to solve it?

Searched quite a bit for other people with this issue but didn't really find anything useful.

Have you tried running in safe mode?

Yes.

Did running in safe mode solve the problem?

Unfortunately, no.

Systeminfo Bundle

octoprint-systeminfo-20211124181552.zip (1.4 MB)

Additional information about your setup

OctoPrint version:1.7.2
OctoPi version: 0.18.0
printer: Voron V2
firmware: Klipper v0.10.0-150-g8b401382
browser: Chrome 96.0.4664.45 (Official Build) (64-bit)
operating system: Windows 10

Summary

This text will be hidden

Hello @jet8300 !
For you run Klipper, you can't use safe mode.

But please enable the serial.log to get information where this M112 comes from.

You may delete Cleanup Logging Package and Terminal Commands. They are not compatible to Python 3.7

I'm running Klipper too, but I have just a print in progress. After this I will try this G4 P3000 issue.

Here is my serial.log (10.2 KB).

Thank you.

So, I tried G4 P3000 and G4 P10000:

Recv: // Klipper state: Ready
[...]
Send: G4 P3000
Recv: ok
Send: G4 P10000
Recv: ok

No problem at all. Maybe a issue with Klipper.