Gcode Preview ALWAYS syncs! Cant change to other layers

What is the problem?


Gcode Preview ALWAYS syncs! Cant change to other layers.
If i wanna go to let say layer 100, it "pulls" me to actuall layer and shows actuall position.

Like i can´t Stop Sync, even if i uncheck the Sync to Job box.

Doesn´t matter on which printer, its always , in all Instances, think since 1.9 or above

I´ve also deinstalled/deactivated some Plugins, like Pretty Gcode Viewer, Octolapse, Firmware Checker...

What did you already try to solve it?

Updatet to1.9.3
Tried other browsers
delete caches

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Yes, then the Behaviour is Normal again

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Update : think uploaded it!

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36


connectivity.connection_ok: True

connectivity.enabled: True

connectivity.online: True

connectivity.resolution_check: octoprint.org

connectivity.resolution_ok: True

env.hardware.cores: 4

env.hardware.freq: 1800.0

env.hardware.ram: 3971350528

env.os.bits: 32

env.os.id: linux

env.os.platform: linux

env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.5

env.plugins.pi_support.octopi_camera_stack: webcamd

env.plugins.pi_support.octopi_version: 1.0.0

env.plugins.pi_support.octopiuptodate_build: 1.0.0-1.8.7-20230302160739

env.plugins.pi_support.octopiuptodate_build_short: 2023.03.02.160739

env.plugins.pi_support.throttle_check_enabled: True

env.plugins.pi_support.throttle_check_functional: True

env.plugins.pi_support.throttle_state: 0x0

env.python.pip: 22.3

env.python.version: 3.9.2

env.python.virtualenv: True

octoprint.last_safe_mode.date: unknown

octoprint.last_safe_mode.reason: unknown

octoprint.safe_mode: False

octoprint.version: 1.9.3

printer.firmware: Marlin 2.1.3 MRiscoC Ender3V2-422-BLTUBL-IS-LA-MPC, based on bugfix-2.1.x (Sep 4 2023 20:19:33)

systeminfo.generated: 2023-10-24T14:03:38Z

systeminfo.generator: zipapi
octoprint-systeminfo-20231024170746.zip (390.6 KB)

Hello @Selim_Basoral !

Blue words are links.

You can upload here:


Please attach it to your next post.

Oh thx, now I saw it! :sunglasses:

upload the zip now! :grimacing:

And to try safe mode, will it only start the one instance or the whole pi then I safe mode? :grimacing:
Because I have some very long prints working on some instances, I don't want to risk abortion.



I was able to Start in Safe Mode and the Behaviour of the GCode Preview Window is again like it should be!

I´ve startet in Normal Mode and its again this weird behaviour....

What is possible the Error ? :frowning:

I´ve also deinstalled/deactivated some Plugins, like Pretty Gcode Viewer, Octolapse, Firmware Checker...

That's a known UI Customizer bug:

Please do uploads always to your next post, not to the initial post. Things can get mixed up.

If it works in safe mode, then one of the 3rd party plugins is faulty.

You can find out by binary search:

Disable one half of the 3rd pry plugins.
If it works, the culprit is in the half you disabled.
If not, the culprit is in the other half.
Divide the half with the culprit and do again. Etc...

BTW: What printer do you have?

i have several different printers! Enders 3 V2, Sidewinders, WinAce and so on.

But the Error is in every of the Octopi Instances.... :face_with_raised_eyebrow:

to be cleear,I have Installed an Instance for every printer, so that i can use them all at once if i want

and also all the instances are up to date, as i take the announcements for updating seriously. they ar all on the same state, except the "first one" which also has Octolapse in.

i´ve tried to disable all thirdparty Plugins, but then i can´t start the print. I can connect, i can heat an move and so on,but the button print does nothing. :unamused:

so i´ve activated all again, then printing is no prob, everything works flawless, except the Gcode Viewer.
so i will try to find out which plugin is interupting the printing if it is disabled.

and then which may occur the error in the viewer! :disguised_face:

Scroll up a bit, I already told you it's UI Customizer that is causing the gcode viewer issue :sweat_smile:

1 Like

Oh my god! :sunglasses:

Yes, there it stays! :see_no_evil:

Will try it wenn come home!
Thx :sweat_smile:

But now I'm also curious which one is preventing the print to start, if deactivated! :grin:

Thx, now its working like Charm again :slight_smile:

Is there a solution for this bug? It was nice to customize the UI to my needs :wink:

The link provided was to a GitHub issue created on the UI Customizer project site. If you look at that issue, the author of the plugin has responded with "I will look asap". I suggest you follow that issue for the most up-to-date information.

1 Like

Yeah, now I saw it! :sunglasses:

That's also the reason I didn't find this topic here!

Will also try to search and look for information there!

Thx @All that helped so quick! :+1:t3::grin:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.