Gcode tab not working

What is the problem?

Hi everyone, I am very new to the 3d printing world so please forgive me if its something obvious, I have done a search.

I have a prusha mk3s set up and printing well. I have hooked up an pi 3b with a camera on and I get good information about print bed/nozzle temps, time remaining etc. However what I do not get is the gcode tab showing where the print head is at. Or more accurately it worked one time. I dont suppose its critical but it was cool to look at :slight_smile:

What did you already try to solve it?

Um, nothing.

Have you tried running in safe mode and if so did it solve the issue?

octoprint.log (109.4 KB)

Complete Logs

log uploaded


`Prusha Mk3S, latest firmware as of today. Octoprint, assuming latest as of today it offered an update yesterday when I first installed it which I accepted.
Working on ethernet not wifi.

There is a checkbox in the bottom right of the viewer called 'Sync with job progress' - make sure that is checked.

Hi thanks for that tip, however its already checked, I tried unchecking and rechecking just in case, no change.

It may be related, maybe not, but your log is flooded with these lines:

octoprint.util.comm - INFO - Communication timeout while printing, trying to trigger response from printer.

Might be worth keeping an eye on the terminal, to see if it is anything specific that is making it timeout.

I wonder if there are more steps I should have taken setting this up, in essence I burnt the microsd with octoprint told it I had a Mk3S and plugged it in.

Check the USB cable you are using, it needs to be high quality (thick and with ferrite beads is a good indicator), interference can cause many problems.