Gcode viewer bugs

Hi all,

  • OctoPrint 1.7.2
  • Python 3.7.3
  • OctoPi 0.18.0

Very pleased with Octoprint, running Octopi with an Ender 3 V2.

I have noticed a couple of bugs with the Octoprint gcode viewer.

  1. Numbering, Octoprint appears to number layers from 0 to N-1 (which is a little distracting because my slicer numbers from 1 to N), However the gcode viewer numbers the layers from 1 to N+1 which is even more distracting! The extra layer is N°2 - with just the purge line on it.

  2. On larger prints the first layer often does not show, sometimes there is just the purge line (or part of it).

This doesn't stop anything from working, so I'm not complaining.

OctoPrint itself doesn't track the layer numbers, but various plugins do. If you have the layers displayed in the state pane, printer LCD, etc you may be using Display Layer Progress and it does have an option to compensate for layers starting at 0. In any case, this would need to be resolved in the particular plugin.

The bundled gcode viewer plugin has an option to skip the purge line:

You may need to see what your slicer outputs, but that will allow you to skip the purge line.

Also: this has nothing to do with Docker, where you've posted this...

2 Likes

Sorry for the post landing in Docker, no idea how that happened.
Thanks for the tips, I will be much less distracted in future...

moved it to #support

1 Like