GCode Viewer stops working after each print

I recently wiped and reinstalled octopi/octoprint for a couple of my printers. Everything is updated. I am having a problem with the gcode viewer. Once a print is complete, the next print I do, the gcode viewer doesn't work. I have to reload the web page for it to work. When I start the 2nd print, the gcode viewer appears to download it's data, then shows nothing, just the empty grid. The Reload button is grayed out and the Reset viewport button does nothing. If I reload the page, it works again until the next print.

Running OctoPi 1.0.0, OctoPrint 1.9.0 on a RaspberryPi 4 4GB with 128GB micro-SD
Google Chrome browser version 114.0.5735.110


1 Like

Bildschirmfoto vom 2023-06-13 23-23-12

What did you already try to solve it?
Wiped and reinstalled. No change

Have you tried running in safe mode?

Did running in safe mode solve the problem?
No. The issue persists even in safe mode

Systeinfo Bundle
octoprint-systeminfo-20230613154544.zip (58.4 KB)

1 Like

I DID notice that if I reprint the same file, without having to reload the file after a print, it works fine. It's only if I start printing a different file after the 1st one without doing a page refresh that I encounter the problem.

1 Like

Tried a different browser?

1 Like

Good point

Yes. That was the first thing I tried. Forgot to mention that.

You may want to try and find the browser console to see if there is an error loading the file. The way files are loaded did change in 1.9.0 so it's possible there's a bug, but it does sound a bit temperamental. If there is an error in the console then that helps a lot, if not then the debugging process is hard.

1 Like

This also is happening to me (just to confirm) It corrects if I do a page reload. Would looking at other plugins also installed help?

A workaround I found is to "Load" the file from the file list before printing., Usually works. Occaisionally it doesn't, but then if I "Load" another file first, then "Load" the one I want to print then it works. If I just click "Print" from the file list, I always have the issue.

Yes, and as mentioned, a "refresh" of the web page also seems to "fix" it.

There has been at least one bug found & fixed in the gcode viewer that will make its way into 1.9.1 that meant it failed to load sometimes after switching files & tabs on the UI.

Even after the latest update, the problem still occurs. It's so annoying to have to refresh the page completely, just so I can do the next print. As someone else also has this issue, then it's not just me and my settings.

I think I found a temporary work around. I also have the PrettyGCode plugin installed. Once a print is done, when I get ready to start the next print, I switch to that plugin, load the next print, then switch back to GCode Viewer and it shows fine.. so far.

Does the gcode viewer work fine in safe mode with OctoPrint 1.9.2?

When I tried before, I still had a problem.. Put aside troubleshooting for a bit. Recently re-addressed the problem. worked ok for a few prints in safe mode. started troubleshooting by disabling one plugin at a time and trying several prints.. I THINK I narrowed the problem down to the PrintTimeGenius Plugin. Will know after a few more prints.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.