Getting the "The OctoPrint server is currently not running" message

What is the problem?

I'm starting an Octopi for the first time and followed Thomas Sanladerer's tutorial but by the time I got to logging in through my PC I get the "The OctoPrint server is currently not running" message.

What did you already try to solve it?

I tried verifying the process was running through an SSH. When I put in the "ps -ef | grep -i octoprint | grep -i python" nothing happened
Tried reinstalling Octopi on the SD card

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Err, I can't seem to figure out how to get that. Not sure I can do the first two, number three just gets me back to the "server is currently not running" page, and I must not be doing the last one right because I get "command not found" and I don't understand the target path instructions.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPi 0.18.0 with OctoPrint 1.7.3 on a Raspberry Pi 3 Model B

If you changed the username when using the Raspberry Pi imager, then don't do that. You'll have to re-do the installation without changing it from pi.

I did indeed change the username. I'll try again without changing it.

That worked! Thanks!

1 Like

I’m having a similar issue with the server not running error. I have changed the username using the imager and it worked fine with no problems until I tried to load octoeverywhere. If I reload the image and have pi as the name, can I then ssh into the unit and change it that way without getting the error? Any ideas on why changing the name in the imager does this?

The OctoPi image is built as the pi user, which means OctoPrint is installed and going to run (when you boot it) from this user's home (/home/pi). When you change the username, the OctoPrint installation is no longer in /home/pi anymore, as this does not exist, and so the automatic startup scripts and services that were expecting this fail to start it.

This is a new option in the Pi imager, and we have not yet worked out how to support changing the username without reworking the whole system - which may be an option, but not preferred due to the sheer number of guides out there that know OctoPrint to be installed in ~/oprint as the user pi.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.