GPX or startup script problem?

I just set up my Octopi server today and am running into some issues while trying to print.
I am using an old "Qidi Tech X-one" printer, I think its a clone of a makerbot possibly, and I am using simplify3D for slicing.

Without the GPX plugin I can connect to the printer and can almost print things, but am having a problem getting the level and homing set correctly. Usually with simplify 3d, printing off the SD card I have a startup script of "g28;home all axis" and this sets the nozzle to the right position before printing, but when using Octopi it ignores my startup script from the .GCODE file and starts printing wherever the nozzle is located. If I put the script into the Octopi startup script it homes and sets the nozzle on the edge of the print bed and starts to heat up which will burn the printbed.

I read that I need the GPX plugin to work with these old printers, I installed the plugin but it will not connect to the printer with the GPX plugin installed. I tried many different machine types (clone R1, Replicator 1, Replicator 2, makerbot, flashforge) and different baudrates, toggling "request exclusive access to the serial port", adding more time for timeouts, and I get the same error each time.

"Unexpected error while connecting to serial port: /dev/ttyUSB1 IOError: 'Serial communication error' @ (hook GPX)"

The serial port is showing /dev/tty/USB1 from the dropdown menu, and if I switch the USB port it goes to /dev/tty/USB0 so I know it is being detected, but im having a hard time troubleshooting this error.

Hi @skittlesv1!

Let's see:

  • OctoPrint does not ignore any of the provided GCODE commands in the file, plugins do.
  • When you had a serial connection with your printer without GPX, the is no need to install GPX. Try again with GPX disabled. The error you mentioned should also disappear. GPX is not used by old printer, but for printers with a different behaviour of the firmware.
  • LOGS (click me!) say more than thousand words. In this case, the serial.log is much appreciated.

Personally, every single print job I do on my printer I manually:

  1. Go to the Control tab
  2. Press the X/Y home button
  3. Press the Z home button
  4. Preheat for PLA
  5. When the temperature gets to at least 170C, extrude 5mm to remove any old filament in the hotend throat
  6. Start the print job

It's just a good practice (when printing in the absolute mode of motor movement) that everything starts in the home position.

As suggested, though, disable the GPX (which is probably bypassing your OctoPrint-stored scripts).